Probem when playing a recordsequence for structured menuitem

Ask general questions here.
luzie
Posts: 1
Joined: Tue May 19, 2009 8:52 am

Probem when playing a recordsequence for structured menuitem

Post by luzie » Tue May 19, 2009 9:24 am

Hello,

I try to test the evaluation version von ranox and have the following Problem when recording and replay a sequence: espacially when using structured menu:


Calling a sub-level Menuitem from a strucuted Menu first time => works fine e.g. "Menuitem1-Menuitem 11-Menuitem 111"

Calling afterwards another Menu-Item e.g. "Menuitem1-Menuitem 12-Menuitem 121"
=> Error: the Menuitem "Menuitem1" was not found


The Steps where shown in Ranorex Studio:

1. Running the first step to execut Menuitem 111 works fine
2. afterwards executing the next Steps to execute Menutitem 121 by "Play Selected Items" works also fine
3. Running complete => DOES NOT WORK


Is there something I do wrong, or ist this a bug in ranorex studio ?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Tue May 19, 2009 10:47 am

Could you please give us the following information:
- the version of Ranorex you use
- in the Report of the failed test, whether there is a warning stating that you should try to disable Caching (if there is, please try to disable "UseCache" for the menu folder in the repository)
- could you send a Ranorex snapshot of your application and the menu to support_at_ranorex.com?

Regards,
Alex
Ranorex Support Team