Problems installing Ranorex on Windows 8

Ask general questions here.
User avatar
Aracknid
Posts: 342
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

Problems installing Ranorex on Windows 8

Post by Aracknid » Tue Nov 20, 2012 3:51 pm

Hi,

Can someone please help me get Ranorex installed on Windows 8? I'm not sure what is wrong...

I have a VM of Windows 8 Enterprise. I've installed VS2012. By default, I do not have Internet Access. When I tried to install Ranorex, it wanted to go to the internet to get .NET 3.5 and/or other Microsoft files that it needs. I was able to get Internet access, and get those required files to install. A restart was required. When it started back up... nothing happened. So I manually ran the setup for Ranorex and It just shows a dialog that says "0% Extracting" and it never progresses.... This dialog appeared the first time (before reboot) and did extract. Nothing seems to be happening now. I've restarted a few times, and still nothing.

Using installer for Ranorex 3.3.4

Thanks,

Aracknid

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Problems installing Ranorex on Windows 8

Post by Support Team » Tue Nov 20, 2012 4:58 pm

Hi,

Could you please uninstall all the installed .Net frameworks and redistributable files and install it again?
Please also uninstall all Ranorex related files.
It could be that there was an issue with those frameworks.
After you reinstalled all the files again please install Ranorex with the following file: Ranorex.

Regards,
Markus
.
Image

User avatar
Aracknid
Posts: 342
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

Re: Problems installing Ranorex on Windows 8

Post by Aracknid » Tue Nov 20, 2012 7:44 pm

After my initial attempt to install and getting the required files to install (or so it seemed), I noticed that if I went to the "Programs and Features" section, in here there was the option to "Turn Windows Features on and off". In this section, there was an entry for ".NET Framework 3.5 (includes .NET 2.0 and 3.0)" and it was NOT on. I checked it on and Windows 8 said it needed to go get updates. After the updates, it was on. I assumed that maybe this was the reason it wasn't working. But it still doesn't work (without doing any of the changes you suggested).

I've turned off .NET 3.5, and I uninstalled the VC runtime files. I restarted Windows and tried again with the newer Ranorex and now it works. I noticed that this installer turned on the .NET 3.5 SP1 features. Is that link to a different 3.3.4 setup package than the one I already have? If so, was the difference with how it installed .NET?

Now it seems to have installed correctly, and is working.

Thanks,

Aracknid

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Problems installing Ranorex on Windows 8

Post by Support Team » Wed Nov 21, 2012 12:00 pm

Hello,

The provided link to 'Ranorex-3.3.4.exe' will install all prerequisites of Ranorex (e.g .NET Framework 3.5). The msi-file contains only Ranorex without prerequisites.

Regards,
Markus (T)
.
Image

User avatar
Aracknid
Posts: 342
Joined: Tue Aug 10, 2010 3:23 pm
Location: Toronto, Ontario, Canada

Re: Problems installing Ranorex on Windows 8

Post by Aracknid » Wed Nov 21, 2012 3:26 pm

Hi, I think there is a bit of misunderstanding here. I already had the 3.3.4.exe from before I posted a problem. That's what I was using when I tried to install the first time. So my question is "Was the 3.3.4.exe that you asked me to download the same as what I already had?" I believe you are saying that it is.

So really, what I'm wondering now is why did it mess up to begin with? Doesn't really matter now since we got it working, but I was thinking that the "solution" was a different installer, when in fact I think it was just cleaning up and starting over.

Aracknid.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Problems installing Ranorex on Windows 8

Post by Support Team » Thu Nov 22, 2012 2:12 pm

Hello,

It seems that you used a Windows 8 version which tried to install .NET Framework via Internet instead of using it from Ranorex installer package. It's hard to find out the reason for this issue. Maybe a Windows Update fixed this issue.

Regards,
Markus (T)
.
Image