Problems with Ranorex Recorder

Ranorex Spy, Recorder, and Studio.
davidthewatson
Posts: 3
Joined: Thu Jan 24, 2008 4:27 pm

Problems with Ranorex Recorder

Post by davidthewatson » Thu Jan 24, 2008 4:42 pm

I am trying to evaluate ranorex recorder 1.3 on Windows Vista with a wxWindows application written in C++. When I start recording, I double click on the exe from Windows Explorer, and then proceed through a series of button click actions in a wizard-style applcation. After several of these actions, I click exit and return to ranorex recorder. However, each time I've tried this, ranorex recorder seems to stop recording at some point in the interaction. This seems to be a bug in the recorder, but I have no idea why it stops and I certainly wouldn't buy it given this experience.

Is there anything that I can do to get it to work correctly?

Thanks,
David

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Fri Jan 25, 2008 2:22 pm

Are you using version 1.3.1?

The RanorexRecorder should only stop recording if you
  • click on the RanorexRecorder task bar icon
  • click on the RanorexRecorder tray icon
  • switch back to the RanorexRecorder window (e.g. by keyboard)
  • press Shift+Escape.
If you haven't performed any of the listed actions, then this might be a bug. Did you notice any particular action that caused the recording to stop?

Perhaps you could also send us a sample of your application so we can have a closer look on the problem.

Regards,
Alex
Ranorex Support Team

davidthewatson
Posts: 3
Joined: Thu Jan 24, 2008 4:27 pm

Post by davidthewatson » Fri Jan 25, 2008 2:39 pm

I have version 1.3. It's a trial. How can I get version 1.3.1?

I had not performed any of the actions that should have stopped recording. The recording seems to stop at the same point each time, i.e. in the same screen in my application. There's nothing unusual about this screen, i.e. just some standard wxWidgets controls.

Unfortunately, it's proprietary, so I can't send a copy for debugging purposes. I will try the 1.3.1 version if you can tell me how to get it.

Thanks,
David

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Fri Jan 25, 2008 3:04 pm

Just download the current evaluation version 1.3.1 from:
http://www.ranorex.com/download.html

Alex
Ranorex Support Team

davidthewatson
Posts: 3
Joined: Thu Jan 24, 2008 4:27 pm

Still broken in 1.3.1

Post by davidthewatson » Fri Jan 25, 2008 5:08 pm

I downloaded the 1.3.1 release and tried the same set of operations on my wxWidgets app, and the behavior changed slightly, but it's still not correct. In particular, a significant part of the navigation that I recorded, several screens worth of button clicking and typing in a few text fields, does not replay. I'll take a look at it in my debugger if I get a chance, or perhaps you could tell me how to report such bugs on a more private channel such that I don't have to post the proprietary bits on an internet forum? Again, I don't mind being a beta tester, but I certainly wouldn't pay money for this.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Tue Jan 29, 2008 9:47 am

If you don't want to post to the forum, you can also send a support query:
http://www.ranorex.com/support.html

Alex
Ranorex Support Team