Problems with running recordings in VPN environment

Ask general questions here.
MichalSk
Posts: 37
Joined: Fri Jul 10, 2020 9:23 am
Location: Pforzheim, Germany

Problems with running recordings in VPN environment

Post by MichalSk » Thu Sep 17, 2020 6:05 pm

Hello,

when working from home and using a VPN client to connect to our company network, I have problems with running recordings. :(
I think I should also mention, that we use McAfee as antivirus software, and this one keeps blocking my recordings, if I'm trying to run them.

All the following attachments are provided in german, but if needed I can translate them :D

If I try to run a recording, McAffee reports the following message:
McAffee_blocking_recordings.png
McAffee_blocking_recordings.png (43.91 KiB) Viewed 284 times
And if go to the McAffee application, I get the following attributes listed:
McAffee_WarningMessages.png
McAffee_WarningMessages.png (33.21 KiB) Viewed 281 times

So basically he is telling me, that while running the "ExecuteContentConsole.Runner.exe", he found as threat type a "Trojaner" :shock:
Like I mentioned, it only happens when I work from Home using our VPN client. Unfortunately I guess I cannot close the McAffee client because it's required in our company.


Thanks in advance!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6545
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Problems with running recordings in VPN environment

Post by odklizec » Fri Sep 18, 2020 7:18 am

Hi,

This is a most common issue with antivirus apps, which are considering Ranorex a threat. McAfee was previously used also in my company and it regularly complained about Ranorex. I'm afraid, you will have to ask your IT department to add Ranorex to McAfee whitelist. There is no other workaround (aside of killing McAfee ;)).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

MichalSk
Posts: 37
Joined: Fri Jul 10, 2020 9:23 am
Location: Pforzheim, Germany

Re: Problems with running recordings in VPN environment

Post by MichalSk » Fri Sep 18, 2020 9:10 am

Hello odklizec,

I already feared it, but thought there might be a workaround :D
Anyway do you have an idea, why this problem rarely happens when I work at the company? McAffee also runs there in the background..
Last edited by MichalSk on Fri Sep 18, 2020 9:20 am, edited 1 time in total.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6545
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Problems with running recordings in VPN environment

Post by odklizec » Fri Sep 18, 2020 9:15 am

Hi,

I'm afraid, I don't have a clue, why it happens only with VPN. Anyway, whitelisting Ranorex should help ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

MichalSk
Posts: 37
Joined: Fri Jul 10, 2020 9:23 am
Location: Pforzheim, Germany

Re: Problems with running recordings in VPN environment

Post by MichalSk » Fri Sep 18, 2020 9:18 am

Alright, thanks for the help! I will ask our IT department to add it to the whitelist.

User avatar
Stub
Posts: 440
Joined: Fri Jul 15, 2016 1:35 pm

Re: Problems with running recordings in VPN environment

Post by Stub » Fri Sep 18, 2020 12:58 pm

I've been running Ranorex across a VPN for years. Works fine here at least, so it's definitely workable in principal.

MichalSk
Posts: 37
Joined: Fri Jul 10, 2020 9:23 am
Location: Pforzheim, Germany

Re: Problems with running recordings in VPN environment

Post by MichalSk » Fri Sep 18, 2020 1:01 pm

Stub wrote:
Fri Sep 18, 2020 12:58 pm
I've been running Ranorex across a VPN for years. Works fine.
The problem comes most likely no from the VPN client, but like @odklizec mentioned, from the McAffee program which causes trouble ;)

MichalSk
Posts: 37
Joined: Fri Jul 10, 2020 9:23 am
Location: Pforzheim, Germany

Re: Problems with running recordings in VPN environment

Post by MichalSk » Fri Sep 18, 2020 3:46 pm

Hello everybody,

thats really weird, I just wanted to write an email to our IT department, but thought let's give it another try, and now I can run the recordings without any problems from McAffee application :lol:

VPN client and McAffee are running normally as before, but now they are not causing any troubles.
Maybe someone from the @RanorexDevTeam have a clue, why sometimes McAffee causes problems and sometimes not?