Problems with Scheduled Test Suite on Virtual Machine

Ask general questions here.
houseofcutler
Posts: 52
Joined: Fri Mar 21, 2014 4:22 pm

Problems with Scheduled Test Suite on Virtual Machine

Post by houseofcutler » Wed Jul 02, 2014 10:31 am

Hi There,

I have created a test suite to be used to check the status of on of our web based applications.

The test suite is executed at regular intervals using Task Scheduler on a 2012 Virtual server.
Security options - Run only when user is logged on. I have tried different configuration options - Server 2008, Server 2012 etc.

The problem I am finding is that the first part of the test script runs successfully - Open a browser - Enter username and password details, click login.
The next module fails as it cannot find the first element. The report shows a picture of a black screen at the point where it failed.

I can confirm that this all works absolutely fine when I am connected to the VM (using RDP) and the screen is open in front of me. If I close the window (although the session remains open as I did not log off) then when the Test script is run it experiences this problem.

I found an old forum post (2010) that relates to this - http://www.ranorex.com/forum/running-au ... t1295.html

There are work around for keeping RDP sessions open while tests are running but as this is something that we want to run every hour all night every day I cannot really rely on having a remote desktop connection open to a VM all the time to achieve this.

Also I tried the registry fix that should stop RDP form locking the session when the window is closed but this does not appear to make a difference.

Is there no way that a Ranorex Test Suite can be executed on a VM unattended and without an open Remote session?

As Always I would very much appreciate some input - it will be a shame if we have to switch to a non Ranorex solution for the status check.

Thanks

Ben

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Problems with Scheduled Test Suite on Virtual Machine

Post by Support Team » Thu Jul 03, 2014 12:29 pm

Hi Ben,

Unfortunately, it is not possible to execute a test without having a user logged into that machine. There are two possible workarounds mentioned here, but again, it’s not possible to execute a test without an active user session.

Thank you for your understanding

Regards,
Robert
.
Image

Amrita
Posts: 1
Joined: Thu Sep 25, 2014 12:56 pm

Problems with scheduling test suites(through .exe file) in V

Post by Amrita » Fri Sep 26, 2014 11:08 am

I am facing one issue while executing testsuites in Virtual machines.

When i am executing the testsuites through .exe file available in \bin\debug Folder. The testsuites crashes out in the middle of the run.

I have attached the screen shot of the error, which comes up after it crashes out.
Please help me out with this. I need a solution to this as soon as possible.
I am stuck with this issue :( :cry: . I am not able to run any testsuites in virtual machine.
Attachments
VM_Issue.png
Attached is the screen shot which shows the error after it crashes out.
VM_Issue.png (240.37 KiB) Viewed 1705 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Problems with Scheduled Test Suite on Virtual Machine

Post by Support Team » Mon Sep 29, 2014 2:29 pm

Hello Amrita,

Does this issue only occur if you execute the test via command line (using the executable)? Crashes the test at a specific point/action?

Please provide as much information as possible.

Regards,
Robert
.
Image