Project just hangs

Ask general questions here.
jackrabbit
Posts: 47
Joined: Wed Mar 18, 2015 10:06 pm

Project just hangs

Post by jackrabbit » Wed Jan 13, 2016 3:13 pm

I have a project that randomly hangs somewhere in my UserCode. Nothing happens, no errors are reported, no report shows up, nothing. I have to click on the X of the DOS window of my test to stop it.

I tried to add Report.Info statements in my code to identify where the code hangs, but as soon as I put any trace info, it no longer hangs, so I cannot identify the reason using trace messages.

I saw in the Global Settings, in the Plugins tab that I can enable Tracing into a RanorexStudio.log file. I looked into this file, and I do not get much usefull informations, all I get is:

2016-01-13 08:51:50.4932|WARN|Ranorex.Controls.TestModuleBrowser|BeginUpdate() - TestModuleBrowser handle is not created.
2016-01-13 08:51:50.4932|WARN|Ranorex.Controls.TestModuleBrowser|TestModuleBrowser handle is not created.

What does this means?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Project just hangs

Post by Support Team » Fri Jan 15, 2016 1:28 pm

Hello jackrabbit,

Unfortunately, I don't think that the extract from the Ranorex log is connected with the issue.

I would suggest debugging through the user code. Using the debugger you should be able to detect the problematic code. More information about debugging in Ranorex Studio can be found in the User Guide.

If you need further assistance, please do let me know.

Sincerely,
Johannes
.
Image