Question About Ranorex7.2.1

Ranorex Spy, Recorder, and Studio.
gubeen
Posts: 1
Joined: Wed Aug 21, 2019 1:56 pm

Question About Ranorex7.2.1

Post by gubeen » Wed Aug 21, 2019 2:18 pm

when I use Ranorex5.2,It works OK.
test.exe's code is below:
1.jpg

test22.exe's code is below:
2.jpg

But,When I update to Ranorex7.2.1,It doesn't work.
The problem is :when test22.exe running to code "if(repo.Form记事本.SelfInfo.Exists())",test22.exe will be stop.

thanks

gubeen
Attachments
1.jpg
1.jpg (35.36 KiB) Viewed 62 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5071
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Question About Ranorex7.2.1

Post by odklizec » Thu Aug 22, 2019 7:08 am

Hi,

I'm afraid, Ranorex 7.2.1 is way too old and no longer supported. You should try the most recent 9.1.1, because I seriously doubt anyone here still keeps 7.2.1? Which means, that there is probably no one, who can even try to reproduce your problem? Seriously, 7.x is a long time dead horse ;)

At next, it's next to impossible to suggest something meaningful without seeing, at very least, Ranorex snapshot of (NOT screenshot) of your app under test (AUT). But I think that in this particular case, it would be required to see the app itself as well. Plus more detailed steps what exactly you trying to do?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration