RadTileView and Silverlight Browser app

Class library usage, coding and language questions.
s2sys
Posts: 2
Joined: Wed Sep 05, 2012 4:58 pm

RadTileView and Silverlight Browser app

Post by s2sys » Wed Sep 05, 2012 5:05 pm

I am testing a SL Browser site, which has RadTileView [url]http://www.telerik.com/help/wpf/t_teler ... eview.html [url] objects. I can get the objects inside the RadTileView ( like the labels and textboxes ) but i cannot get the RadTileView container object itself

Does anyone have a work around for this?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: RadTileView and Silverlight Browser app

Post by Support Team » Thu Sep 06, 2012 2:58 pm

Hello,

In order to check if there is a valid UI Automation implementation you can try to identify the elements using the Microsoft UISpy. If UISpy cannot identify the elements it seems that there is no valid implementation. In that case Ranorex cannot identify the elements because Ranorex uses UI Automation for the identification for such elements. Could you please send us a Ranorex snapshot file in order to analyze the issue in detail.

Regards,
Bernhard
Ranorex Support Team
.
Image

s2sys
Posts: 2
Joined: Wed Sep 05, 2012 4:58 pm

Re: RadTileView and Silverlight Browser app

Post by s2sys » Thu Sep 06, 2012 9:13 pm

UISpy did not see the RadTileView, but was able to view children objects. Looks like this is an issue with theTelerik control http://www.telerik.com/help/silverlight ... pport.html

Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: RadTileView and Silverlight Browser app

Post by Support Team » Fri Sep 07, 2012 2:58 pm

Hello,

As you said it seems to be a problem with the control. If UISpy is not able to identify the element there is no other way than to re-implement UIAutomation.

Regards,
Bernhard
Ranorex Support Team
.
Image