Ranorex 3.0 slow loading

Ask general questions here.
tallahassee101
Posts: 169
Joined: Thu Jan 13, 2011 2:06 pm

Ranorex 3.0 slow loading

Post by tallahassee101 » Fri Mar 04, 2011 6:36 pm

Ranorex 3.0 is having some issues with loading on our project. It takes 15 seconds after Ranorex opens our project before we can click anywhere on the screen, during this time there is no progress bar and clicking anywhere causes the window bar to say "(Not Responding)". Ranorex takes 15 seconds to rebuild and to close with our project as well with the same issue. The biggest problem is there is no visual feedback of what is going on, Ranorex just appears to freeze for 15 seconds, then returns as if nothing happened.
In addition if I open a bunch of recordings ( about 10 ) it takes 10 seconds to do a "Close All Documents", even if there are no changes to save.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 3.0 slow loading

Post by Support Team » Tue Mar 08, 2011 3:42 pm

Hi,

as mentioned in your post:
http://www.ranorex.com/forum/ranorex-re ... html#p7731
this behaviour will be limited as good as possible in our next release.

The visual feedback is added to our feature list and will be added in future.

Kind regards,
Tobias
Support Team
.
Image

tallahassee101
Posts: 169
Joined: Thu Jan 13, 2011 2:06 pm

Re: Ranorex 3.0 slow loading

Post by tallahassee101 » Thu Mar 24, 2011 7:20 pm

This behavior is separate from the earlier issue I reported. This is an issue that is specific to 3.0. In addition to the other slowdowns I reported the other major place I am seeing slowness is on pressing the play button for running a test. It takes about 5-10 seconds to build/start the test and during that time my computer's performance goes from 1% to over 50% and becomes fairly impossible to use. It does the same thing when a test ends.
This becomes quite burdensome when trying to write tests and wanting to test a small section ( even right clicking on a test item and doing a play of just a single test item causes this 10 second delay and slowness ).

The behavior is also similar to the behavior on startup, there is no loading information on the screen and it gives the impression that the tool is about to crash, when in fact it is loading.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 3.0 slow loading

Post by Support Team » Fri Mar 25, 2011 10:12 am

Hi,

as mentioned before the performance on on start up and replaying a recording will be getting better in our next release dramatically by enhancing the automatically performed code generation. And, of course, a visual feedback will be added too.

So, please be patient...

Kind regards,
Tobias
Support Team
.
Image

tallahassee101
Posts: 169
Joined: Thu Jan 13, 2011 2:06 pm

Re: Ranorex 3.0 slow loading

Post by tallahassee101 » Fri Mar 25, 2011 2:05 pm

Sorry to bring this up multiple times, I am in the process of training other employees in the tool and this issue has been continuously slowing us down. I wanted to documented all instances of the issue and ensure it was being addressed to let our managers and lead engineers know.
Thank you for the support.

tallahassee101
Posts: 169
Joined: Thu Jan 13, 2011 2:06 pm

Re: Ranorex 3.0 slow loading

Post by tallahassee101 » Tue Apr 05, 2011 6:35 pm

Is 3.01 supposed to have these performance upgrades mentioned? I updated our systems today and they still have the same lag on startup, building, and running tests.

User avatar
Gunner1980
Posts: 89
Joined: Mon Apr 05, 2010 8:44 pm
Location: Austin, Texas

Re: Ranorex 3.0 slow loading

Post by Gunner1980 » Tue Apr 05, 2011 7:59 pm

I also downloaded 3.0.1 and have not seen an improvement in performance? Was this supposed to be in this release? There was no mention of performance enhancements in the release notes. Build times are killing me right now.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 3.0 slow loading

Post by Support Team » Wed Apr 06, 2011 1:32 pm

Hi,

As these performance fixes have a huge influence on our whole product and we do not want to release these performance fixes without reviewing and massive testing, these performance enhancements will come with our next service release 3.0.2 which will estimated be availbale till the end of april.

Kind regards,
Tobias
Support Team
.
Image