Ranorex 4.0.2 screenshots not captured on errors

Ask general questions here.
let
Posts: 17
Joined: Wed Oct 20, 2010 7:00 pm

Ranorex 4.0.2 screenshots not captured on errors

Post by let » Wed Feb 13, 2013 10:15 pm

I just recently upgraded from Ranorex 3.3.3 to Ranorex 4.0.2. Our code is organized into 5 projects that are part of the same solution file. We do not use test suites to run tests. We do not have any recordings (all tests and methods are written as code)

When I run a "test" (basically a method, such as Navigation.ClickEachLink();), the report file (.rxlog) is being generated as I would expect, but if the test hits an exception and fails, screenshots are not being generated as part of the report file. When the same test is run under Ranorex 3.3.3, screenshots are included in the .rxlog and placed in the same directory as the .rxlog.

I'm also noticing that there are no .rxlog.data files being generated. I see from the release notes this is one of the big changes that is part of Ranorex 4.x. Will the .rxlog.data files be generated only if I'm running a test suite?

Here's how we're setting up the .rxlog:
Report.Setup(ReportLevel.Info, reportName, false);
Report.Start();
Report.Log(ReportLevel.Info, testName);
f.Run(TestTestByGroup.Rows, project, env, browser, fgtid, "", debug);
Report.End();

Since I'm getting the .rxlog file, obviously reporting is working.

What do I need to do to get screenshots on failures captured again?

hs.fk
Posts: 12
Joined: Thu Jul 12, 2012 11:47 am
Location: Hamburg

Re: Ranorex 4.0.2 screenshots not captured on errors

Post by hs.fk » Thu Feb 14, 2013 6:55 pm

I encountered the same issue (probably) XmlLogger.LogData produces no output

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 4.0.2 screenshots not captured on errors

Post by Support Team » Fri Feb 15, 2013 11:17 am

Hi,
let wrote:What do I need to do to get screenshots on failures captured again?
This is a bug in this version with the old 2.x Report. We will fix this bug in the next version.

Regards,
Peter
Ranorex Team
.
Image

omayer
Posts: 458
Joined: Thu Oct 28, 2010 6:14 pm

Re: Ranorex 4.0.2 screenshots not captured on errors

Post by omayer » Fri Feb 15, 2013 3:49 pm

i don't see any screen captured using report.screenshot() on 4.01
Thanks,
Tipu

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 4.0.2 screenshots not captured on errors

Post by Support Team » Mon Feb 18, 2013 5:35 pm

Hi,

I posted an answer to your problem here: Screenshot method.

Regards,
Markus
.
Image