Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Bug reports.
krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by krstcs » Wed Jun 01, 2016 7:20 pm

Ranorex 5.4.6
Windows 10 Pro x64 (upgraded from Window 7 Pro x64)
Hard-iron laptop (not a VM) i5/16Gb Ram

Note: I have already done a clean reinstall. We are not moving to 6.0.0 until the first bug patch.

After upgrading my system to Windows 10 Pro, the Shift-Pause key-combination no longer skips delays during test runs, but instead interrupts and cancels the test run as if only the Pause key was pressed. Pause alone still works as expected (so the functionality wasn't flipped).

The upgrade went very smoothly, no issues at all. Visual Studio and all other software (besides Ranorex) is working fine. I'm not sure this is an issue with the upgrade itself.

The same test setup worked fine before the upgrade, Shift-Pause skipped delays and timeouts correctly.
Shortcuts usually aren't...

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by krstcs » Wed Jun 01, 2016 7:24 pm

This looks similar to this thread: http://www.ranorex.com/forum/skip-delay ... t8647.html

However, I am not using any key-UP/DOWN actions at any point in these tests, and the only thing that has been done is that my keyboard and mouse are disabled (but, again, this is the same as it was before the upgrade and it worked fine before).

In addition, my caps lock is NOT on (first thing I checked).
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by Support Team » Wed Jun 08, 2016 3:52 pm

Hi Kelly,

Sorry for not replying sooner. Thank you for reporting this issue. I already added it to our internal bug-tracking system.

Currently, we do not know if and when this issue will be fixed. This depends on various factors. Nevertheless, all reported bugs and feature requests are documented in the release notes, with every new version release of Ranorex.

Thank you for your understanding.

Sincerely,
Johannes
.
Image

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by krstcs » Mon Jun 20, 2016 5:03 pm

Just another note:

This does not seem to be an issue in 6.0.0, however, there are a few factors that might come into play:

1. I installed a clean install of Windows 10 on a VM as opposed to the upgrade on my laptop.
2. I installed the VM guest additions.
3. I then installed Ranorex 6.0.0, so it was the only application on the system (no Visual Studio, Office, other drivers, etc.)

In this situation, Shift-Pause works correctly, skipping delays but not ending the test.
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by Support Team » Thu Jun 23, 2016 12:14 pm

Hi Kelly,

Thank you for this update. I noted this information in our internal bug-tracking system.

Sincerely,
Johannes
.
Image

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by krstcs » Tue Dec 27, 2016 5:19 pm

Ranorex 6.1.1
Windows 10 Pro (1607)

This issue has popped up again. Pressing 'Shift-Pause' stops test execution instead of skipping delays, as if only the 'Pause' key was pressed.

I'm not sure when it started because I have not been using this key combo lately, but I can confirm that it is still an issue.
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by Support Team » Wed Dec 28, 2016 3:06 pm

Hi krstcs,

Thank you for the information. Unfortunately, I am not able to reproduce the issue on my side. The original issue in this thread should be fixed in Ranorex 6.0.0.
Did you try if the issue still persists in Ranorex 6.2?

Sincerely,
Bernhard
.
Image

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by krstcs » Thu Dec 29, 2016 5:38 pm

Unfortunately, no. Currently, we do not move to a new feature release until it has at least one patch, due to the need for more mature feature sets in our tests.

When I get a chance I will see if I can get a VM with 6.2 and check again, but currently the only Win10 system I use is my laptop.
Shortcuts usually aren't...

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex 5.4.6 - Shift-Pause not skipping after Win10 upgrade

Post by krstcs » Tue Feb 14, 2017 7:49 pm

I have now tried this on 6.2.1, and the issues is still present. 'Shift-Pause' acts like 'Pause', and exits the test instead of skipping delays.

Edit to add: Just genned up new W10 VM for the "special project" I was invited to by Roland and it doesn't have this issue, not sure if it is the "special application" or the new install of 10. I may try re-installing my laptop from scratch instead of the upgrade and see what that does.
Shortcuts usually aren't...