Ranorex 6 - Debug mode is not released after execution.

Bug reports.
ujjainkarh
Posts: 5
Joined: Fri Jul 10, 2015 6:39 am

Ranorex 6 - Debug mode is not released after execution.

Post by ujjainkarh » Thu May 26, 2016 1:23 pm

The new feature of "Enable Debugging" -

I am facing problem while using this feature. While execution if you enable Debug mode then after completing execution, debug mode is not released after clicking button.

Steps to reproduce:
1. Select test case to execute by enabling debug mode.
2. Execute test case.
3. After execution, disable debug mode by clicking button or ctrl+F5.

All functionalities should be available for releasing debug mode.

I am not able to -
1. Enable or disable code modules used in test case by clicking right mouse button.
2. If you open data binding, data source, Data range and Manage Data source options are disabled.
3. Change data binding.
4. Perform context menu operations

In order to use all functionalities, need to reopen .rxtst file.

Same is applicable to object repository.

Can you please check at your end?

Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 6 - Debug mode is not released after execution.

Post by Support Team » Tue May 31, 2016 3:11 pm

Hi ujjainkarh,

Unfortunately, I couldn't reproduce the issue on our test environment. I would suggest contacting [email protected] in order we can schedule a short remote session to analyze the issue on your machine directly.

I look forward to hearing from you.

Sincerely,
Johannes
.
Image