Ranorex 7.1 upgrade -- error

Ask general questions here.
Jimmyto
Posts: 18
Joined: Wed May 10, 2017 7:37 pm

Ranorex 7.1 upgrade -- error

Post by Jimmyto » Fri Jun 30, 2017 2:39 pm

Hi all,

Just completed the Ranorex upgrade and suddenly received this error after trying to run a TC.

Could not load file or assembly 'Newtonsoft.Json, Version=8.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) (InnerException: -- )

I've created a new TC since this one was converted to newest version and reloaded the JiraReporter in which currently working on and still receive the error.

I've looked at the pacakages.config file and can see the line (below) but what will be the new value?

<package id="Newtonsoft.Json" version="8.0.3" targetFramework="net40" />

Any help is greatly appreciated and Thanks in advance!!
Jimmy

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Ranorex 7.1 upgrade -- error

Post by asdf » Mon Jul 03, 2017 1:13 pm

Hi Jimmy,

I would recommend just adding the NuGet package "Ranorex Jira Reporter" again to your project.
You could also use "Install-Package Ranorex_JiraIntegration -Version 7.0.1.1" in the package management console in order to install the NuGet Package.

Please let us know, if this helps you to overcome your problem.

Sincerely,
asdf

Jimmyto
Posts: 18
Joined: Wed May 10, 2017 7:37 pm

Re: Ranorex 7.1 upgrade -- error

Post by Jimmyto » Mon Jul 10, 2017 6:59 pm

Hi asdf and Thanks for your suggestion.. was out on vacation :D

Ok, so, remove it and added again and still same error. Any other suggestion? or maybe someone can provide the version to try?

Thanks in advance!!
Jimmy

Jimmyto
Posts: 18
Joined: Wed May 10, 2017 7:37 pm

Re: Ranorex 7.1 upgrade -- error

Post by Jimmyto » Mon Jul 10, 2017 7:50 pm

looking at my references
Newtonsoft.Json --> Properties version 6.0.0.0

packages.config
Newtonsoft.Json --> version=8.0.3


Could this be the problem? I've updated the version to match the reference to 6.0.0.0 still... not working!

Remove the reference Newtonsoft.Json --> Properties version 6.0.0.0 from my reference, reinstalled it and same problem.

Could this be a Ranorex 7.1 bug? :shock:

This began after I upgrade to 7.1, last resource will be rolling back to 7.0. Just glad I'm the only one the upgraded to 7.1 for testing purposes.

Jimmyto
Posts: 18
Joined: Wed May 10, 2017 7:37 pm

Re: Ranorex 7.1 upgrade -- error

Post by Jimmyto » Tue Jul 11, 2017 12:57 pm

@RanorexSupport team..

Do you guys have an answers for this issue?

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex 7.1 upgrade -- error

Post by krstcs » Tue Jul 11, 2017 4:25 pm

If you want a quick answer from Ranorex support, you should email them at [email protected] (if in US timezones) or [email protected]. They are usually much more responsive through email.
Shortcuts usually aren't...

xeronar
Posts: 28
Joined: Mon May 22, 2017 8:19 pm

Re: Ranorex 7.1 upgrade -- error

Post by xeronar » Wed Jul 12, 2017 8:38 am

Hey everyone,

I'm having the same issue as mentioned in another topic (https://www.ranorex.com/forum/jira-inte ... 11055.html), I've contacted the support and they said that they can reproduce it: "Adding Jira references to Ranorex 7.0.1 worked as expected, but there seems to be an issue when adding them to Ranorex 7.1.0."

So they are keeping track of it and will inform me/us if they got more information according to this problem.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 7.1 upgrade -- error

Post by Support Team » Mon Jul 17, 2017 12:11 pm

Hello Everyone,

This issue occurs since Ranorex 7.1.0 and will be fixed in one of our next releases.
However, we suggest using the workaround described under the following link in the meantime:

https://www.ranorex.com/forum/jira-inte ... tml#p44819

Thank you for your understanding.

Regards,

Stephan
.
Image

Jimmyto
Posts: 18
Joined: Wed May 10, 2017 7:37 pm

Re: Ranorex 7.1 upgrade -- error

Post by Jimmyto » Wed Jul 19, 2017 2:39 pm

Hi Xenorar & everyone,

If that workaround does not work please try this.. This Solution was provided by Jon support team from Ranorex and worked for me.

1. Create a new blank solution in Ranorex
2. Convert the target framework to version 4.5.2
3. Save and Close Ranorex Studio
4. Open the solution using Visual Studio (2017 recommended, I am using the free community version)
5. Add the Ranorex Jira packages
6. Close Visual Studio
7. Open the solution in Ranorex Studio and Build the solution

Thanks!
Jimmy