Ranorex 8.3.2 does not generate cs files.

Ask general questions here.
BorisS
Posts: 14
Joined: Fri Jul 11, 2014 2:25 pm

Ranorex 8.3.2 does not generate cs files.

Post by BorisS » Wed Jan 16, 2019 12:57 pm

We store project in a perforce repository, so only a .UserCode.cs file from each testcase is stored. Currently, I checked out the complete TestSystem on a new machine and found, that this Ranorex Version cannot generate missing .cs files. It is obviously a bug.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4772
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 8.3.2 does not generate cs files.

Post by odklizec » Wed Jan 16, 2019 1:11 pm

Hi,

Storing UserCode.cs files is not enough! You must store also rxrec files. Additionally, to generate cs files from rxrec files, the solution must be open in Ranorex Studio. There is no way to generate cs files with msbuild! In other words, if you are planning to build and run your solution on target computer (different than computer where you designed the test suite), you must store both rxrec and cs files in you source control system. Otherwise, you will be forced to (manually) open the solution in Studio, which will re-generate all cs files.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

BorisS
Posts: 14
Joined: Fri Jul 11, 2014 2:25 pm

Re: Ranorex 8.3.2 does not generate cs files.

Post by BorisS » Thu Jan 17, 2019 10:52 am

We store rxrec files. But this RS version does not generate cs file from rxrec and UserCode.cs file. If fails with the CS001

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4772
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 8.3.2 does not generate cs files.

Post by odklizec » Thu Jan 17, 2019 10:57 am

Hi,

I just tried it with new solution (where I deleted recording cs files) and once I loaded it, missing cs files were correctly regenerated. Have you tried it with another solution (e.g. new one)?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Stub
Posts: 229
Joined: Fri Jul 15, 2016 1:35 pm

Re: Ranorex 8.3.2 does not generate cs files.

Post by Stub » Fri Jan 18, 2019 9:43 am

What about the .rxrep Repository files that also generate .cs files?

BorisS
Posts: 14
Joined: Fri Jul 11, 2014 2:25 pm

Re: Ranorex 8.3.2 does not generate cs files.

Post by BorisS » Fri Jan 18, 2019 2:28 pm

It seems the problem is in msbuild. I checked the issue on window10 machine with VS2017 installed and on the W7 vm without this installation.
on windows10 all files were generated on W7 not. The package message on W10 is
"C:\Program Files (x86)\Ranorex\AddIns\Misc\PackageManagement\NuGet.exe" restore "QM-00240.sln"
MSBuild auto-detection: using msbuild version '15.8.169.51996' from 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\15.0\bin'.
Nothing to do. None of the projects in this solution specify any packages for NuGet to restore.

The message on W7 is

"C:\Program Files (x86)\Ranorex\AddIns\Misc\PackageManagement\NuGet.exe" restore "QM-00240.sln"
MSBuild auto-detection: using msbuild version '4.0' from 'C:\Windows\Microsoft.NET\Framework64\v4.0.30319'.
Nothing to do. None of the projects in this solution specify any packages for NuGet to restore.


I don't see any other differences in this two installations

User avatar
Stub
Posts: 229
Joined: Fri Jul 15, 2016 1:35 pm

Re: Ranorex 8.3.2 does not generate cs files.

Post by Stub » Fri Jan 18, 2019 4:39 pm

Do you need to install the MS Build Tools on the Win7 box?