Ranorex 9.0 - Debugger not starting

Ranorex Spy, Recorder, and Studio.
User avatar
mariaspeigl
Posts: 7
Joined: Mon Jan 07, 2019 11:50 am
Location: Germany (Bavaria)

Ranorex 9.0 - Debugger not starting

Post by mariaspeigl » Tue Apr 02, 2019 3:20 pm

Hello,

we have the problem that the AUT does not start when debugging mode is enabled.
Image

Without debugging mode everything works fine.

There is always a black logging screen with no text:
Image

When stopping the session, Ranorex hangs.
Some months ago it was no problem to use the debugging mode.
I am always starting Ranorex as administrator.

Where may be the problem here?
I used different projects, already deinstalled Ranorex - nothing works...

Many thanks in advance!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4549
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 9.0 - Debugger not starting

Post by odklizec » Wed Apr 03, 2019 7:30 am

Hi,

Unfortunately, it's hard to tell what's wrong, without seeing your problem in action. It could be somehow related to your app under test, but I rather suspect it's somehow related to your environment or eventually, corrupted solution? Could you please check these few things?

Have you tried to debug a clean new solution, created with 9.0?
Have you tried another solution, converted from previous Ranorex version?
Have you tried to debug the same solution on another PC?
Have you tried to uninstall Ranorex and install it back?
Make sure your antivirus/GOP does not interfere with Ranorex (try to temporarily disable Antivirus and ask your IT folks about GOP).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration