Ranorex 9.3.1 doesn't delete cache

Ask general questions here.
russ
Posts: 7
Joined: Tue Jun 25, 2019 6:33 pm

Ranorex 9.3.1 doesn't delete cache

Post by russ » Tue May 05, 2020 5:38 pm

Hi,

This is an issue I have encountered when upgrading to 9.3.1. I have specified for the test to delete the cache in the 'Open Browser' properties panel. Howwever, it doesn't seem to be doing anything. Is this a bug in 9.3.1?

Thanks
Russ

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6358
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 9.3.1 doesn't delete cache

Post by odklizec » Thu May 07, 2020 11:07 am

Hi,

With which browser are you experiencing this problem?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

russ
Posts: 7
Joined: Tue Jun 25, 2019 6:33 pm

Re: Ranorex 9.3.1 doesn't delete cache

Post by russ » Thu May 07, 2020 12:44 pm

Hi thanks for getting back to me.

I am using Chrome and Edge Chromium as a cross browser test, but even if I use a single browser it doesn't seem to recognize the property change.

I have used it on several different websites, including www.ranorex.com, with no luck.

Russ

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6358
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 9.3.1 doesn't delete cache

Post by odklizec » Thu May 07, 2020 12:58 pm

OK, an important question. Are you sure that Chrome is entirely closed at the end of test? You see, Chrome (and Chromium-based Edge too) by default does not terminate entirely if the browser window is closed. And I think this is also the reason why the cache is not cleared? There is an option in settings (both in Chrome and Edge), which must be unchecked to make the browser to terminate for good. Go to browser's settings and search for "Continue running background apps when Google Chrome/Edge is closed" and uncheck it.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

russ
Posts: 7
Joined: Tue Jun 25, 2019 6:33 pm

Re: Ranorex 9.3.1 doesn't delete cache

Post by russ » Thu May 07, 2020 1:58 pm

hI,

Yes I have those unchecked on both browsers, before I started creating the tests (read through the browser pre-requisites)

Just another piece of info. This is only creating a test with open and close browser. It doesn't even have any other recording modules.

Thanks
Russ