Ranorex 9 - @Visible='true' being ignored?

Bug reports.
ancleg
Posts: 11
Joined: Thu Dec 20, 2018 4:03 pm

Ranorex 9 - @Visible='true' being ignored?

Post by ancleg » Thu Feb 14, 2019 5:12 pm

I have an xpath that contains "@visible='true'" in the deepest level of the xpath. However when I spy with it, it is finding some entries that have "Visible=False"

I'd prefer not to post a snapshot but will post a screenshot of what I'm seeing in spy -> https://imgur.com/t3TkwPf

It is finding the first two items correctly, but the third, as shown, has "Visible" -> "False" yet is still showing up.

Edit: When I save a snapshot and open that, it opens in Standalone Spy. There, the "visible=true" does seem to apply, but not within the Spy launched from Studio.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4421
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 9 - @Visible='true' being ignored?

Post by odklizec » Fri Feb 15, 2019 9:12 am

Hi,

I'm using @Visible a lot in my tests and I'm not experiencing such issue with R9.0? True, I'm not testing SAP-based app, but this should not matter? ;) I think the best you can probably do is to contact directly Ranorex support (via their support form) and request a remote session with them, so they can evaluate the problem in realtime. Without seeing the app under test and actual Ranorex settings, there is very little (if anything) anyone here can do or suggest.

BTW, have you tried to switch back to Ranorex 8.3.2 and evaluate the same xpath?

And one more thing. If standalone spy shows different results than spy started from studio, please check if both spy uses the same settings! Standalone spy and spy started from studio have different set of settings. So try to export the settings from standalone spy and load them in spy started from Studio.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Support Team
Site Admin
Site Admin
Posts: 11774
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 9 - @Visible='true' being ignored?

Post by Support Team » Fri Feb 15, 2019 11:51 am

Hello ancleg,

We introduced a performance feature which could cause this issue in specific situations.
Would you mind trying to disable the setting "Enable JS acceleration for ID9+ without addon" in the plugin settings?
In order to do so please open settings dialog in Ranorex Studio or Ranorex Spy and open the Plugins tab. Navigate to the section "Web" and disable the setting.

Please let me know if this doesn't fix your problem.

Regards,
Bernhard
.
Image

ancleg
Posts: 11
Joined: Thu Dec 20, 2018 4:03 pm

Re: Ranorex 9 - @Visible='true' being ignored?

Post by ancleg » Fri Feb 15, 2019 8:12 pm

Support Team wrote:
Fri Feb 15, 2019 11:51 am
Hello ancleg,

We introduced a performance feature which could cause this issue in specific situations.
Would you mind trying to disable the setting "Enable JS acceleration for ID9+ without addon" in the plugin settings?
In order to do so please open settings dialog in Ranorex Studio or Ranorex Spy and open the Plugins tab. Navigate to the section "Web" and disable the setting.

Please let me know if this doesn't fix your problem.

Regards,
Bernhard
That setting (I assume you typoed IE9+, there is no ID9+) is already disabled. Also I am using Chrome, so I'm not sure an IE toggle would affect it.

@odklizec, I have filed a support ticket as well. They have been able to reproduce and are looking into it at that end. I did not jump back to 8.3.2 but I am really trying to avoid moving backwards. We aren't in urgent need of being able to run tests right this moment or else I probably would be panicking :)

Thanks for your ideas.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11774
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex 9 - @Visible='true' being ignored?

Post by Support Team » Wed Feb 20, 2019 5:19 pm

Hello everyone,

After further investigation, we found that our new web performance improvement is causing this issue. Deactivating the setting “Enable JS-based RanoreXPath evaluation” should fix the issue.

Please open the settings dialog in Ranorex Studio (or Ranorex Spy) and navigate to the Plugins tab. Search for the Web section and disable the setting “Enable JS-based RanoreXPath evaluation”.

I hope that helps.

Regards,
Bernhard
.
Image