Ranorex 9 support for Micorosft Unified Service Desk

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
ivanchokees
Posts: 1
Joined: Wed Jun 12, 2019 1:50 am

Ranorex 9 support for Micorosft Unified Service Desk

Post by ivanchokees » Wed Jun 12, 2019 1:52 am

Hi,

I’m trying to create automation scripts with Ranorex 9.0.1 for an application hosted in Microsoft Unified Service Desk v.4.1.1.1253 (USD). To give you a background, USD uses Chromium/Cefbrowser in the background to host web applications. Whenever I’m locating an element within USD, it takes me a minute to locate the element and then actually performing the action (e.g. click, select combobox value). Also, sometimes locators/xpaths work, sometime it doesn’t – it’s very temperamental.

Is USD really supported by Ranorex? Will there be a future fix for this?

Cheers,
Ivan

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4918
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex 9 support for Micorosft Unified Service Desk

Post by odklizec » Thu Jun 13, 2019 1:43 pm

Hi,

At first, could you please post a Ranorex snapshot (NOT screenshot) of USD/particular problematic element and the xpath you are using in repository? Without snapshot and xpath, it's impossible to suggest something reliable. Also, I would strongly suggest to update your Ranorex 9.0.1 with recent 9.1, because it fixes many problems. I don't expect it will fix also your issue, but one never knows? ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration