'Ranorex.ApplicationNotRespondingException'

Ask general questions here.
RyanL0618
Posts: 1
Joined: Wed Jul 04, 2018 4:44 pm

'Ranorex.ApplicationNotRespondingException'

Post by RyanL0618 » Wed Jul 04, 2018 4:56 pm

Hi, I've been trying to run a test case and I cannot get it to run through it without it throwing 'Ranorex.ApplicationNotRespondingException', I've increased the adapter.functionexecutiontimeout like it says on other answered questions however this doesn't seem to fix my issue, I'm using Ranorex 8.1.
anyone know what else i should try?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 'Ranorex.ApplicationNotRespondingException'

Post by Support Team » Fri Jul 06, 2018 2:59 pm

Hello RyanL0618,

May I ask a few further questions on this topic?

Do you get this exception on a specific element, or do you get it immediately when starting your application?
Is Ranorex and the AUT started with the same user permissions?

Usually the increasing the value for the adapter.functionexecutiontimeout setting works. Did you try a higher value?

Also, we released a new version (Ranorex 8.2) this week. Would you mind trying if the issue persists in the new version as well?

Sincerely,
Bernhard
.
Image

swmatisa
Posts: 122
Joined: Fri Aug 05, 2011 7:52 am

Re: 'Ranorex.ApplicationNotRespondingException'

Post by swmatisa » Tue Jul 10, 2018 3:07 pm

Hello,

adapter.functionexecutiontimeout can be in 2 files (Ranorex.rxsettings and RanorexConfig8.xml). So modify in Ranorex.rxsettings first
SW