Ranorex Automation Add-on could not be verified in Mozilla

Ask general questions here.
Arun_Singh
Posts: 3
Joined: Thu Jun 16, 2016 12:57 pm

Ranorex Automation Add-on could not be verified in Mozilla

Post by Arun_Singh » Thu Jun 16, 2016 1:54 pm

Hello,

Currently I'm using Ranorex-5.3.3 version. I have gone through the Instrumentation Wizard of Ranorex User Guide and found that If Mozilla Firefox has been installed before installing Ranorex, the Mozilla Browser Add-On will be installed and activated automatically, but currently my "Ranorex Automation" Add-on is in disabled state. In Mozilla Browser addons page, it does not give me the option of either enabling or disabling the add-on as it says that "Ranorex Automation Add-on could not be verified for use in Firefox and has been disabled".
I'm using the latest Mozilla Firefox version 47.0

Please find the attachment for more detail.

Thanks & Best Regards,
Arun Singh
Attachments
Mozilla Browser Add-on not verfied.png
Mozilla Browser Add-on not verfied.png (106.71 KiB) Viewed 876 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex Automation Add-on could not be verified in Mozilla

Post by odklizec » Fri Jun 17, 2016 9:33 am

Hi,

Ranorex 5.3.3 is a pretty old version and only supports Firefox up to version 39 (see the release notes). Ranorex added version independent support for Firefox (41 and higher) in Ranorex 5.4.2. In other words, if you want to use Ranorex with latest FF, you will have to upgrade at least to version 5.4.2, but I would suggest to go to latest 6.0.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Arun_Singh
Posts: 3
Joined: Thu Jun 16, 2016 12:57 pm

Re: Ranorex Automation Add-on could not be verified in Mozilla

Post by Arun_Singh » Fri Jun 17, 2016 10:01 am

Hi odklizec,

Thanks for your valuable feedback.
As you suggested in the previous comment, I have upgraded my Ranorex Studio to latest Ranorex-6.0.0 version in order to use it with the latest version of Mozilla Firefox(47.0). But this time I'm getting the message "Ranorex Automation is incompatible with Firefox 47.0".

Still my Ranorex Automation add-on is in disabled state and no option is available to make it enable.
Could you please check what's the matter now?
Please find the attached screenshot for more detail.

Thanks & Best Regards,
Arun Singh
Attachments
add-on is incompatible with Firefox 47.0.png
add-on is incompatible with Firefox 47.0.png (77.99 KiB) Viewed 870 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex Automation Add-on could not be verified in Mozilla

Post by odklizec » Fri Jun 17, 2016 10:21 am

Hi,

It seems you don't have a new Ranorex plugin (Ranorex Automation NG) installed but the legacy one. Please follow the steps described here and install the required plugin manually:
http://www.ranorex.com/forum/problem-fi ... tml#p34764
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Arun_Singh
Posts: 3
Joined: Thu Jun 16, 2016 12:57 pm

Re: Ranorex Automation Add-on could not be verified in Mozilla

Post by Arun_Singh » Fri Jun 17, 2016 11:08 am

Hi,

Thanks for the information.
I have installed the new Ranorex plugin (Ranorex Automation NG) and it works fine.

Thanks & Regards,
Arun Singh