Ranorex building but not running

Bug reports.
kks
Posts: 1
Joined: Thu Sep 13, 2012 1:45 pm

Ranorex building but not running

Post by kks » Mon Feb 04, 2013 12:31 pm

Hello -

OS: Windows 7 Pro SP1
Ranorex version: 4.0.1.21107

I haven't had problems with this before and only in the last two or so weeks (and I can't pinpoint exactly what changed that made this start to happen). Basically, I can't get Ranorex to run. Whenever I press the "Run" button, it builds (successfully) and then just ends. Only when I run it "without attached debugger" does it actually run the code. I would like to be able to run selected steps, etc. but all other options just builds and stops, no errors, nothing.

How can I fix this? Is it some setting that I accidentally set?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex building but not running

Post by Support Team » Tue Feb 05, 2013 1:51 pm

Hello,

Have you changed anything in your project settings (e.g. Debug settings)?
Have you set a 'Break Point' in your Code?
Do you get a 'Console Window' if you start your test normally?

Could you please create a new solution with a short recording and try to run it?
(Example: Open Calculator and click on a button.)
Do you get the same result?

Regards,
Markus (T)
.
Image