Ranorex can't identify objects on a specific page in Chrome

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
SurajJaldu
Posts: 29
Joined: Sat Feb 25, 2012 12:10 am

Ranorex can't identify objects on a specific page in Chrome

Post by SurajJaldu » Fri May 02, 2014 7:04 pm

Hello Support team,

Ranorex was unable to identify the objects on a specific page in Google chrome while it identifies them very well in IE and FireFox.

I have attached snapshot files of DOM object for both Chrome and FireFox. In Chrome browser, 'Middle' frame contains no objects while all objects can be found under 'Middle' frame in FireFox.

Note that this page needs a certificate. I am not sue if it is the reason for this behaviour.

Thanks,
Suraj
Attachments
FireFox.rxsnp
Snapshot file for FireFox
(78.92 KiB) Downloaded 100 times
Chrome.rxsnp
Snapshot file for Chrome
(12.7 KiB) Downloaded 113 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex can't identify objects on a specific page in Chrome

Post by Support Team » Mon May 05, 2014 7:15 pm

Hello Suraj,

Please make sure you have instrumented the Chrome browser with the Ranorex Instrumentation Wizard.
Additionally, please install all required certificates.

http://www.ranorex.com/support/user-gui ... hrome.html

Regards,

Ranorex Support
.
Image

SurajJaldu
Posts: 29
Joined: Sat Feb 25, 2012 12:10 am

Re: Ranorex can't identify objects on a specific page in Chrome

Post by SurajJaldu » Wed May 07, 2014 7:15 pm

I got a new minor version of Chrome 34 installed in my machine and now Ranorex is identifying none of the objects on any page and on any web page.

I am surprised that no one has complained till now on this forum. How can I get a resolution to this major problem?

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex can't identify objects on a specific page in Chrome

Post by krstcs » Wed May 07, 2014 8:08 pm

Did you ensure that the Ranorex extension in Chrome is enabled as support asked?

You also need to be in Developer Mode in Chrome (check the Developer Mode checkbox in the extensions page).

Are you getting a popup from Chrome about unsafe extensions (you should be)? You need to click cancel on that popup (do not click disable or it will disable the Ranorex extension that it is pointing to).
Shortcuts usually aren't...

SurajJaldu
Posts: 29
Joined: Sat Feb 25, 2012 12:10 am

Re: Ranorex can't identify objects on a specific page in Chrome

Post by SurajJaldu » Wed May 07, 2014 8:37 pm

Hello krstcs,

I have checked and everything looks good. Did you get the latest Chrome (which was released over the weekend, I guess) and try spying on any website? Is everything normal for you?

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex can't identify objects on a specific page in Chrome

Post by krstcs » Wed May 07, 2014 10:05 pm

Yeah, I'm running 34 as well, and mine is fine.

You might try uninstalling Ranorex.

1. Uninstall Ranorex.
2. Reboot.
3. Re-install Ranorex.
4. Ensure Chrome extension is enabled and working.
Shortcuts usually aren't...