Ranorex cannot find Qt elements in GraphicsView

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Gav
Posts: 27
Joined: Thu Oct 20, 2011 10:52 am

Ranorex cannot find Qt elements in GraphicsView

Post by Gav » Fri Mar 28, 2014 4:03 pm

We're using Qt's Webkit widget, powered by their GraphicsView as part of a new UI. We've found that Ranorex cannot identify any of the page objects. We have copied all Qt accessibility plugins into the application's directory and created the qt.conf file as per the advice in Ranorex Help but to no avail.

Does anyone have any ideas of how to get around this issue?

Thanks,

Gav

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex cannot find Qt elements in GraphicsView

Post by Support Team » Wed Apr 02, 2014 10:17 am

Hello Gav,

Unfortunately we are currently not supporting QT Webkit widgets. We are planning to release a QT plugin for better object recognition within the third quarter this year.
We consider the integration of Qt Webkit support if it could be done with a reasonable expense.
Thank you for your patience.

We preserve the right to change the Roadmap whenever necessary! Features might not be in a certain Release, as well as Delays might occur.

Regards,
Robert
.
Image

Gav
Posts: 27
Joined: Thu Oct 20, 2011 10:52 am

Re: Ranorex cannot find Qt elements in GraphicsView

Post by Gav » Fri May 09, 2014 3:48 pm

Hi there,

In case anyone else out there has experienced this issue, we have found a way for Ranorex to correctly identify elements. We implemented QAcessibleInterface and mapped DOM elements onto accessible controls.

Gav