Ranorex cannot open the iOS app and keeps exiting

Mobile Testing, Android App Testing.
hkher
Posts: 1
Joined: Tue Jan 28, 2014 9:07 am

Ranorex cannot open the iOS app and keeps exiting

Post by hkher » Tue Jan 28, 2014 9:38 am

Hi,

I added an iOS device (iPhone 5S) through the Manage Devices section in the USB mode. I have an instrumented app created after following the Ranorex instrumentation steps.

On deploying the app through the Instrumentation wizard or New Recording screen and clicking 'Start', Ranorex tries a few times to open the app but keeps exiting. After it fails a few times, the following message is displayed in a dialog box:

"Cannot start application because another debugger is attached. Please close the currently running application on the device to terminate all active debugging sessions"

Ranorex running on machine: Windows 7 Professional 64-bit
Ranorex version: 4.1.4
iOS device: iPhone 5S 7.0.4

I tried closing all the running applications and then clicking 'Start' but it displays this error each time. Please suggest a solution.

We already have a license with a Ranorex server running in our environment. If the tool is useful, we will continue purchasing the licenses and other services, so your help in this matter is really appreciated.

Regards,
Hursh

User avatar
mebner
Posts: 61
Joined: Tue Dec 17, 2013 6:42 pm

Re: Ranorex cannot open the iOS app and keeps exiting

Post by mebner » Fri Jan 31, 2014 11:47 am

Hi Hursh,

Have you already tried to restart your device and then to establish a debug session again?
It should help in such situations.

Regards,
Markus