Ranorex creates duplicate objects in repository

Ask general questions here.
Fizaliss
Posts: 3
Joined: Tue May 19, 2009 1:28 pm

Ranorex creates duplicate objects in repository

Post by Fizaliss » Wed May 20, 2009 11:36 am

Hello,

1) Since the recording is always rewriting all the changes I make to the script manually in the code, I copy that code to another file and always delete recording to get only new lines for my code from it. From some moment Ranorex Studio started to create new definitions for already defined buttons, textfields etc. instead of using the ones already written in the repository. Can I do something about it?

2) I have the following situation - I need to create a new user and then press "new" in the TreeView for it. But the line I recorded works only if the user was already open when I started to playback the script. Is this problem caused by the problem #1? I mean, when I record the script fully at once everything works, but when I add just the line I need for working with TreeView into the code I created yesterday it can't find the TreeView anymore.

It's possible that my question is not understandable.. sorry if so, I am new to Ranorex

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Fri May 22, 2009 11:53 am

The Ranorex repository reuses element definitions as long as their RxPath stays the same. The path may change, for instance, if the text of a button element changes. From paragraph 2) of your post I assume that something in your application changes, e.g. the title of the treeview, when you add a new user.
Please, inspect the paths of the elements that cannot be found and try to change the paths so that they do not depend on information in your GUI that changes after adding a user.

Regards,
Alex
Ranorex Support Team