Ranorex doesn't time out?

Bug reports.
atkiwi
Posts: 9
Joined: Fri May 18, 2018 5:17 pm

Ranorex doesn't time out?

Post by atkiwi » Thu Aug 23, 2018 7:02 pm

I am currently using Ranorex Test Suite Runner in Admin mode on a VM.

When I run the solution sometimes a step will use the maximum allotted time and will not time out. The progress bar will reach the end and stay like that for up to 20 minutes. Sometimes when I click around and shuffle through screens to make the element disappear / reappear it will become responsive but sometimes it doesn't. This seems to be random and not effect any particular step more than others. I can no longer run the entire suite unsupervised but can do portions with this error happening less often.

If I run these steps directly from the recording module, this does not seem to be a problem.

I am currently using Ranorex version 8.

Thanks!
Attachments
timeout.PNG
timeout.PNG (7.4 KiB) Viewed 118 times

McTurtle
Posts: 191
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Ranorex doesn't time out?

Post by McTurtle » Fri Aug 24, 2018 12:39 pm

Hello atkiwi,

This has happened to me before. The reason was that Ranorex was stuck within some dom element. Try to disable the following setting:
Settings.png
Settings.png (24.81 KiB) Viewed 106 times
Does this help?

Regards,
McTurtle