Ranorex fails to find objects when running tests in SAP ERP

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
chris_l
Posts: 3
Joined: Tue Aug 29, 2017 8:57 am

Ranorex fails to find objects when running tests in SAP ERP

Post by chris_l » Tue Aug 29, 2017 10:52 am

Operating system: Windows 10 Enterprise 6.2
Ranorex version: 7.1.0 without Ranorex EXE Manifest Files installed
SAP ERP: SAP Scripting Support is active

When we are using Ranorex or Ranorex Spy, the software is able to identify and highlight all necessary items in SAP GUI. Also recording works properly and creates correct actions. However, we are facing the issue, that after recording and starting a test, Ranorex is unable to perform simplest actions and fails every time. The error message in the log is:

Failed to find item 'XYZ'. No element found for path 'XYZ'.

Ranorex itself performs actions correctly with applications other than SAP. Are there any solutions you can provide to solve this issue regarding SAP? With previous version 6.x we had no problems running tests on SAP GUI.

Thanks in advance!

Best regards,
Chris

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Ranorex fails to find objects when running tests in SAP ERP

Post by asdf » Wed Aug 30, 2017 6:33 am

Hi Chris,

Have you already tried to explicitly run Ranorex Studio and SAP with administrative privileges?

Best regards,
Asdf

chris_l
Posts: 3
Joined: Tue Aug 29, 2017 8:57 am

Re: Ranorex fails to find objects when running tests in SAP ERP

Post by chris_l » Wed Aug 30, 2017 12:31 pm

Hi asdf,
thank you for your answer. Unfortunately it makes no difference whether opening the application with or without administrative privileges. Ranorex still can‘t execute tests in the SAP GUI.

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Ranorex fails to find objects when running tests in SAP ERP

Post by asdf » Thu Aug 31, 2017 9:43 am

Hi Chris,

Does this problem also occur, when you execute the whole TestSuite?

chris_l
Posts: 3
Joined: Tue Aug 29, 2017 8:57 am

Re: Ranorex fails to find objects when running tests in SAP ERP

Post by chris_l » Mon Sep 04, 2017 10:35 am

Yes, unfortunately the same behaviour. The error occurs every time Ranorex tries to execute recorded actions and find SAP GUI elements. I don’t know if it’s related to my problem, but when executing recordings with TestSuite the following warning occurs:

This control (from process 'saplgpad') seems to be a Windows Forms control, but was not recognized as such, possibly due to a security limitation. UI element identification capabilities for this control may be limited.
If this control is a WinForms control, please make sure that the automating process has the rights to access the automated application. Otherwise, please ignore this limitation.
Process: 'saplgpad' (pid 5548)
The following website provides more information on this technology limitation:
(This message is only shown once per report.)

asdf
Posts: 174
Joined: Mon Mar 21, 2016 3:16 pm

Re: Ranorex fails to find objects when running tests in SAP ERP

Post by asdf » Tue Sep 05, 2017 3:23 pm

Hi Chris,

I would suggest, contacting directly the Ranorex Support team. suppo[email protected]
They will do a remote session with you if necessary and will help you to resolve this problem.

Kind regards,
asdf