Ranorex Firefox plug-in error

Bug reports.
smilinglyqing
Posts: 12
Joined: Thu Sep 29, 2011 7:00 pm

Ranorex Firefox plug-in error

Post by smilinglyqing » Thu Sep 29, 2011 7:13 pm

Hello,

I doing some UI automation for FireFox using Ranorex. however, I got a annoying problem which is about Ranorex FF plugin. Everytime I start Firefox, there is an error window pops up which complains that :
Ranorex Error:TypeError: Components.classes[cid] is undefined

when I close firefox, there another error windows pops up complains that: TypeError: rxAutomation3 is undefined

I am using Firefox 7 and Ranorex 3.1. I have attached the screen shot.
Any idea I can resolve this issue?


thanks
Lisa Li
Attachments
RanorexFFPluginErr.zip
Plug in error window screen shot
(37.24 KiB) Downloaded 248 times

User avatar
slavikf
Posts: 104
Joined: Mon Sep 13, 2010 9:07 pm
Location: Toronto, Canada
Contact:

Re: Ranorex Firefox plug-in error

Post by slavikf » Thu Sep 29, 2011 9:05 pm

As said in another thread:
With 3.1.1 we will support Firefox 7 too. This release should be available in two weeks or so.

h2oman
Posts: 1
Joined: Fri Jun 10, 2011 5:11 pm

Re: Ranorex Firefox plug-in error

Post by h2oman » Fri Sep 30, 2011 3:21 pm

I am using Firefox 6 and getting the same errors - Ranorex Error:TypeError: Components.classes[cid] is undefined and TypeError: rxAutomation3 is undefined whenever a tabpage or the browser is opened or closed.

h2oman

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Firefox plug-in error

Post by Support Team » Mon Oct 03, 2011 8:50 am

Hi,

Which version of Ranorex do you use? If you use Ranorex 3.0.x, this is okay. Firefox 4,5,6 support was added with 3.1.

Regards,
Peter
Ranorex Team
.
Image

mdgairaud
Posts: 87
Joined: Sun Aug 05, 2012 11:59 am
Location: Bilbao, Spain

Re: Ranorex Firefox plug-in error

Post by mdgairaud » Fri Dec 21, 2012 11:15 am

Hello,

Same problem with Ranorex 4.0.1 and Firefox 13.0.
Turning off the Ranorex complement fix the problem.

Tested in W7 64bits and WXP SP3. Also tested with IE9 and works fine.

Any idea or workaround?

Thanks,
Mateo

[edit]. Ranorex 4.0.1 was installed over a previous installation of 3.3.4

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Firefox plug-in error

Post by Support Team » Fri Dec 21, 2012 4:42 pm

Hello,

Please take a look at the breaking changes section of the release notes of Ranorex version 4.0:
"Removed support for older Firefox versions which are no longer supported by Mozilla -> use one of the supported versions: Firefox 3.6, 10 ESR, 15, 16, 17".

Regards,
Markus
.
Image