Ranorex form element coming as null when spying swing window

Ask general questions here.
nagendra5858
Posts: 1
Joined: Wed Nov 02, 2016 9:41 am

Ranorex form element coming as null when spying swing window

Post by nagendra5858 » Wed Nov 02, 2016 10:21 am

I have a popUp container, inside which I have a DefaultComboBoxModel. The model contains a JComboBox which has a list of Machine name.

When I just spy the JComboBox, it shows the xPath as /form[@title='MachinePage']/container[@type='JPanel']//combobox[@name='MachinePopup']

But when I spy a Machine from the ComboBox i get the xPath as /form//container/list[@name='ComboBox.list']/listitem[@text='Ferrari']

I dont get the form name here. Can anyone say why?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3932
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex form element coming as null when spying swing window

Post by odklizec » Wed Nov 02, 2016 3:01 pm

Hi,

Please upload a Ranorex snapshot (not screenshot!) of the combobox in question. I'm not quite sure what you mean by "But when I spy a Machine from the ComboBox". So please upload the snapshot. It's the best way to share a problematic part of GUI with us, so we can examine it and suggest a solution. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration