Ranorex freezes while saving Snapshot

Bug reports.
Kostja
Posts: 6
Joined: Tue Apr 12, 2016 8:28 am

Ranorex freezes while saving Snapshot

Post by Kostja » Tue Apr 12, 2016 8:51 am

Hello everybody,

i'm new to this Forum and just recently started my experience with ranorex. Everything works fine but when i try to initiate a table Validation by saving a snapshot of the the desired table (as mentioned in the section for Code examples) ranorex freezes (see attached Picture).

I waited for approximately 15 minutes for the saving to be finished but it still remains in this state.

Can anybody tell me what the Problem is? Is it because the table isn't recognized as a table properly? Is there any other way to validate the Content of a table?

The AUT is written in WPF/DevExpress.

Thanks for help in advance.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex freezes while saving Snapshot

Post by odklizec » Tue Apr 12, 2016 11:13 am

Hi,

Have you tried to save the snapshot without complete ancestor subtree? Please follow the steps mentioned here:
http://www.ranorex.com/forum/browsing-v ... tml#p33974
Basically, it should save the selected table, without the unnecessary bits.

Also, what's your Ranorex version? If something older than 5.4.6, try to update it with most recent version.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Kostja
Posts: 6
Joined: Tue Apr 12, 2016 8:28 am

Re: Ranorex freezes while saving Snapshot

Post by Kostja » Tue Apr 12, 2016 12:10 pm

Hey,

thanks for your reply. After i updated to 5.4.6 (had 5.4.5) i got the problem solved. But the issue wasn't the version it was due to a specific plugin setting. (Although deactivating the complete ancestor subtree also fixed the Problem)

When WPF Legacy/UI Automation is set to WPFOnly and/or WPF Preferred than it freezes, but when it is set to UIA only then everything works fine and the object is recognized as a table. (UIA Only was the default setting after the Installation of the new version)
Attachments
table_solved.png
table_solved.png (24.7 KiB) Viewed 614 times

jma
Posts: 111
Joined: Fri Jul 03, 2015 9:18 am

Re: Ranorex freezes while saving Snapshot

Post by jma » Tue Apr 19, 2016 6:44 am

Hi Kostja,

I assume that it gives only the appearance of being frozen. Usually, creating a WPF snapshot could take a long time because the UI structure of WPF applications is very complex. Furthermore, I can see from your screenshot that you set the option Show All Elements to true, which makes the UI tree even more complex because the elements are not filtered.

Nevertheless, if object recognition with UIA is sufficient, I would suggest keep using the UIA plugin.