Ranorex hangs on Windows 10 VM

Bug reports.
scythe1123
Posts: 1
Joined: Mon Mar 14, 2016 11:13 am

Ranorex hangs on Windows 10 VM

Post by scythe1123 » Mon Mar 14, 2016 12:41 pm

Hello,
I'm having problem with running compiled Ranorex solution on Windows 10 64/32 bit on VM.
It often ends hanging up. It hangs in different places in test code.
Version of Ranorex which I'm using is 5.4.4.
Attachments
win10.png
win10.png (66.65 KiB) Viewed 1128 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex hangs on Windows 10 VM

Post by Support Team » Tue Mar 15, 2016 3:08 pm

Hello scythe1123,

Welcome to the Ranorex forum!

Unfortunately, it is very difficult to figure out the cause of the issue without more detailed information.
May I ask to contact [email protected]? Then, we can initiate all further steps to analyze the issue.

Thank you in advance.

Sincerely,
Johannes
.
Image

BSullivan
Posts: 29
Joined: Thu Jun 04, 2015 6:31 pm
Location: HorseHeads NY
Contact:

Re: Ranorex hangs on Windows 10 VM

Post by BSullivan » Fri Apr 15, 2016 3:14 pm

Was a cause found for this issue?

I am also experiencing something similar, but not just In Windows 10.

Thanks!!!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex hangs on Windows 10 VM

Post by Support Team » Mon Apr 18, 2016 9:47 am

Hello BSullivan,

Unfortunately, we are waiting for more detailed information from scythe1123 concerning the above-mentioned issue.

In order to analyze your issue, I would need more information, too. Which version of Ranorex do you currently use? Could you describe the issue in more detail and let us know if the issue is reproducible? It would be great if you could provide screenshots and a compressed Ranorex Report to illustrate the issue.

If you want, you could also send this information to [email protected].

I look forward to hearing from you.

Sincerely,
Johannes
.
Image

eturjeman
Posts: 4
Joined: Mon Jul 03, 2017 9:30 pm

Re: Ranorex hangs on Windows 10 VM

Post by eturjeman » Mon Jul 03, 2017 10:42 pm

Hi All,
I am also experiencing something similar only on Win10x32 & 64 as well.

I tell you all information I have:
# In my environment it's look like the process freeze, because there is no failures or any timeout.
when I check the process in "prosses explore" the state is still running and "Wait:User Request".
# In addition, when I click on Windows key the process was continue until the next freeze.
# I'm using ranorex 6.1.1 (And this issue reproduce with 7.0 as well), with .net runtime version 4.0.30319.42000.
# There is no any ranorex report, I mean the process was freeze and I stopped the test manually, so there is no failures.
# This issue was recover even without any wait or sleep call on my code.
# My tests run on win 7x32/64 and 8x32/64 without any problem.

Please see the file attached and let me know if do you need something more.
This issue
Attachments
Screen Shot 2017-07-03 at 11.35.46 PM.png
Screen Shot 2017-07-03 at 11.35.46 PM.png (109.19 KiB) Viewed 577 times
Screen Shot 2017-07-04 at 12.32.44 AM.png
Screen Shot 2017-07-04 at 12.32.44 AM.png (168.14 KiB) Viewed 577 times