Ranorex has low performance when testing Flex apps

Ask general questions here.
alex
Posts: 63
Joined: Sat Oct 08, 2011 11:17 am

Ranorex has low performance when testing Flex apps

Post by alex » Wed Dec 14, 2011 6:08 pm

Hi,
Now I'm using Ranorex to test Flex applicatons. Use the first method(Preloader) to instrument automation lib.
I found that Firefox has low performance during testing. It frequently hangs about ten seconds or more when using Ranorex Spy or runing scripts. This interferes our testing seriously. I'm afraid that case execution will be interrupted when this happens.

IE doesn't have this issue.

Also I wonder that the Ranorex permance will be good or not if using the second way(Automation Lib) to load automation lib.

Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex has low performance when testing Flex apps

Post by Support Team » Thu Dec 15, 2011 6:46 pm

Hi,

Please update to Ranorex 3.2 and try that once again and give us feedback on the performance with the new version.

Thank you!

Regards,
Martin
Ranorex Support Team
.
Image

alex
Posts: 63
Joined: Sat Oct 08, 2011 11:17 am

Re: Ranorex has low performance when testing Flex apps

Post by alex » Fri Dec 16, 2011 2:03 am

Hi,
I'm using Ranorex 3.1.2. I will update to 3.2 and try it.

Thanks.

alex
Posts: 63
Joined: Sat Oct 08, 2011 11:17 am

Re: Ranorex has low performance when testing Flex apps

Post by alex » Sat Dec 17, 2011 9:04 am

Hi,
Ranorex 3.2 still has low performance.
First, Firefox says a script is busy and has no response. Then I select to stop script, finally the flash player is crashed.

Please check attachmants for more information.

Thanks.
Attachments
flashlog.txt
(3.25 KiB) Downloaded 143 times
errorstack.txt
(3.59 KiB) Downloaded 140 times
firefoxscript.png
firefoxscript.png (91.42 KiB) Viewed 749 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex has low performance when testing Flex apps

Post by Support Team » Mon Dec 19, 2011 12:20 pm

Hi,

as mentioned in following reply on your forum post it will help us analyzing your issue, if you could give us access to your application under test:
http://www.ranorex.com/forum/flex-listp ... tml#p11740

Regards,
Tobias
Ranorex Support Team
.
Image

alex
Posts: 63
Joined: Sat Oct 08, 2011 11:17 am

Re: Ranorex has low performance when testing Flex apps

Post by alex » Wed Dec 28, 2011 11:03 am

Hi,
Any response about this?

Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex has low performance when testing Flex apps

Post by Support Team » Fri Dec 30, 2011 12:18 pm

Hi,

We have installed vSphere in houes, but we've never seen this issue you reported above. Is this in some special case of vSphere or just on each page you try to automate?

Regards,
Peter
Ranorex Team
.
Image

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex has low performance when testing Flex apps

Post by Support Team » Mon Jan 02, 2012 11:03 am

Hi,

The best way to solve your problems/issues and answer your questions might be a remote session.

We will contact you to find a date within calendar week 2 for the remote session.

Best Regards,
Martin
Ranorex Support Team
.
Image