Ranorex is not identifying mainframe screens

Experiences, small talk, and other automation gossip.
faheem412
Posts: 13
Joined: Tue Oct 10, 2017 8:52 am

Ranorex is not identifying mainframe screens

Post by faheem412 » Fri Aug 03, 2018 12:38 pm

Hi team,

Currently we are using Ranorex version 7.0 and have few scenarios to automate mainframe screens.
But due Microsoft patch updates, Ranorex is not identifying mainframe screens.
It only identifies when we uninstall the patch updates in regular basis.
Could you please guide us if any work around available to bypass this?

Regards,
Faheem

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex is not identifying mainframe screens

Post by Support Team » Mon Aug 06, 2018 9:19 pm

Hi faheem412,

First, try Ranorex 8.2 to ensure this issue has not already been fixed in one of the 12+ releases since. If the issue persists in Ranorex 8.2, next, let us make sure this is not caused by a lack of permissions.
  1. Run your Ranorex test and/or Ranorex Studio with administrative privileges
  2. Disable Windows UAC
  3. Ensure Ranorex, your Ranorex test, and your Ranorex solution are stored on a local, non-shared, non-encrypted drive
If you are still experiencing issues, please provide the following so I may better understand your environment and further investigate.
  1. The specific patch version/number that causes the issue
  2. Two Ranorex Snapshots of your application - one created before the patch is applied, and one after
  3. Ranorex Trace logs with the patch applied (zip the log folder directly after trying to track the elements with Ranorex Spy). You can find the logs here: %userprofile%\Documents\Ranorex\Logs
I hope this helps!

Cheers,
Ned
.
Image