Ranorex is stuck during execution

Ask general questions here.
mirih87
Posts: 11
Joined: Tue Jul 08, 2014 1:54 pm

Ranorex is stuck during execution

Post by mirih87 » Wed Jul 08, 2015 2:19 pm

I executed Ranorex (version 4) .
Ranorex is get stuck during the execution.

It is stuck at the this line :

if (repo.Folder.FileInfo.Exists())


No error is thrown!!


Please assist!

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex is stuck during execution

Post by krstcs » Wed Jul 08, 2015 4:54 pm

First and foremost, version 4 is no longer supported. You need to update to a current, supported version (5.3.3 or 5.4.0 currently). There have been numerous bug fixes and new functionality added since 4.

Second, when listing version numbers, list the FULL VERSION NUMBER, i.e. '5.3.3' or '4.2.4', etc. This will allow us to understand exactly which version you are using and what issues there might be.

Finally, please ALWAYS include the following when raising an issue on the forums:

Full Ranorex version
Full Windows version
Full Browser version (if applicable)
Technology of system under test (SUT), i.e. HTML, Flash/Flex, Java, WPF, etc.
RanoreXPath of element in question

And most importantly, a Ranorex Snapshot of the element in question.

If you can't post any of that info here, you can send it to [email protected].



My guess would be that your timeout is too high or that there is a problem with the cache, but without more info it is hard to tell anything.
Shortcuts usually aren't...