Ranorex key shortcuts and params w/ selenium grid issues

Ask general questions here.
JeshuaCooper
Posts: 2
Joined: Mon Jun 19, 2017 7:31 pm

Ranorex key shortcuts and params w/ selenium grid issues

Post by JeshuaCooper » Mon Jun 19, 2017 7:46 pm

I seem to be having a problem using a key shortcut of Ctrl+W and also issues using global parameters (to a test suite) while running a ranorex test on a selenium grid. Any ideas why Ctrl+W or global parameters wouldn't translate right?
Version: Ranorex 7
OS: Windows 10
Browser: IE

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex key shortcuts and params w/ selenium grid issues

Post by Support Team » Mon Jun 19, 2017 8:43 pm

Hello Jeshua,

Is there an error produced on the key shortcut action? What is the purpose of pressing Ctrl+W in your selenium webdriver test? Typically, this is the hotkey to close the current tab in the browser. This will not work in a selenium webdriver since you are interacting with the DOM directly, not the browser (which handles the hotkey). Instead, use the 'Close Application' action to close the selenium web driver instance.

The only purpose I can see for pressing Ctrl+W is if you have a key listener listening for this key combination on your website, which would be bad design since this will close the browser outside selenium webdriver testing. Nonetheless, you can test if the key is actually being pressed here.

Regarding your issue with global parameters, please provide more information on what the issue is. What is the behavior are you observing versus what you expect? The more details, the better we will be able to assist you.

I hope this helps!

Cheers,
-Ned
.
Image

JeshuaCooper
Posts: 2
Joined: Mon Jun 19, 2017 7:31 pm

Re: Ranorex key shortcuts and params w/ selenium grid issues

Post by JeshuaCooper » Mon Jun 19, 2017 9:09 pm

Hi Ned,

I figured that was the case with ctrl+W. We are in fact using it to close a tab and that is why it is not working with Selenium web-driver. I am still a little new to Ranorex and wanted to make sure that the key press events were an operating system move and not a web move.

For the global variables, they seem to be working now. I must have pressed a wrong button somewhere for them to have not resolved. The original issue was that they were not being taken from the global and being left blank, but that stopped happening without me touching anything.

Thank for the help. I appreciate it.

-Jeshua

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex key shortcuts and params w/ selenium grid issues

Post by Support Team » Tue Jun 20, 2017 8:29 pm

Thank you for the update - I am very happy to hear everything is working as expected now. Please do let us know if you need any further assistance as we will be glad to provide support.

Cheers,
Ned
.
Image