Ranorex License Server Service Not Starting

Ranorex Spy, Recorder, and Studio.
AccidentReport
Posts: 76
Joined: Tue Dec 04, 2012 2:30 pm

Ranorex License Server Service Not Starting

Post by AccidentReport » Tue Sep 03, 2013 9:19 am

The machine that I have our Ranorex License Server installed on needed to be rebooted yesterday and all seemed fine. this morning however I am finding that I cannot get a license from the server. When I check the license server tool it errors stating that "Not connected to Ranorex License Server. Please check that the Ranorex License Server service is running!" I checked the services and indeed it is not running. However when I try to start the service it takes a long time before erroring saying "Could not start the Ranorex License Server service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion"

What's the best action to take from here? Since I can't start the tool I can't transfer the licenses and I don't know if I can just reinstall a new version over the top.

Please help as this has stopped me in my tracks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex License Server Service Not Starting

Post by Support Team » Tue Sep 03, 2013 2:46 pm

Hello,

Please try to uninstall the Ranorex License Server completely and restart the machine after doing this. Please try to install the newest version of the Ranorex License Server Tool and check if this solves the problem.
Is the machine connected to the internet?
Please make sure that the port 7266 for TCP and UDP is open and not blocked by the firewall.
Please read the section "Installing a Floating License" in our user guide in order to get more information how to use the Ranorex License Server Tool.

Regards,
Bernhard
.
Image