Ranorex.Report.xsl changes are getting lost

Ask general questions here.
vivrai
Posts: 20
Joined: Tue Jun 27, 2017 2:43 pm

Ranorex.Report.xsl changes are getting lost

Post by vivrai » Mon Aug 21, 2017 11:04 am

Hi,

I am running my test scripts using driver script and not through Ranorex suite. I want customize my Ranorex report so I modified the Ranorex.Rport.XSL file but those are getting lost on each execution. Report is also same and no customization is done.

Any one here has any idea about it?

I am using Ranorex version 5.4.1.

Thanks,
Vivek

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3949
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex.Report.xsl changes are getting lost

Post by odklizec » Mon Aug 21, 2017 1:21 pm

Hi,

I'm afraid, Ranorex 5.4.1 is way too old and no longer supported. Anyway, to make changes in report, you need to create a custom report template (as described here) and then edit xsl file of this report template.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

vivrai
Posts: 20
Joined: Tue Jun 27, 2017 2:43 pm

Re: Ranorex.Report.xsl changes are getting lost

Post by vivrai » Mon Aug 21, 2017 1:49 pm

I checked n I don't find those option in 5.4.1 to create customized report. But just confirm me one thing,the given steps to create customized Ranorex.Report.XSL file will also generate customized report when we are running the test scripts using our own Driver scripts and not Ranorex suite file? I generally don't use Ranorex suite to execute my test scripts

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3949
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex.Report.xsl changes are getting lost

Post by odklizec » Mon Aug 21, 2017 2:09 pm

Hi,

I'm afraid, I'm not able to help you with this. I'm no longer using 5.x so I can't comment its custom report capabilities. And because all my work is done completely in Studio, I don't have the need or knowledge of custom reporting API.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
N612
Posts: 62
Joined: Mon Jul 11, 2016 4:01 pm

Re: Ranorex.Report.xsl changes are getting lost

Post by N612 » Mon Aug 21, 2017 8:43 pm

Based on my testing (in Ranorex 7.1.1), you will need at least a test suite file (*.rxtst) to use custom reports. The test suite file is an XML based, and within it contains a <testsuite> node with a 'reporttemplatefolder' attribute where you can specify the custom report template location.

Sample:

Code: Select all

<testsuite
	ReportTime="RelativeToTestSuiteStartTime"
	TracingScreenshotMode="Foreground"
	TracingScreenshotQuality="40"
	enabletracingscreenshots="True"
	id="0332f041-9c54-4c3d-b9cc-97c4924cfb06"
	name="SampleProject"
	placescreenshotsinfolder="True"
	reportcompress="False"
	reportfilename="%S_%Y%M%D_%T.rxlog"
	reporttemplatefolder=".\NewCustomTemplate1\" <<<<<<<<<<<<<<<<<<<<<<<
	reportwriteinterval="30000ms">
</testsuite>