Ranorex Reports not loading in Chrome v48

Ask general questions here.
User avatar
jasoncleo
Posts: 37
Joined: Mon Jun 08, 2015 7:37 am

Ranorex Reports not loading in Chrome v48

Post by jasoncleo » Thu Jan 28, 2016 3:21 am

Back on the 20th January 2016, Google Chrome v48 was released. The problem we have, is that our Continuous Integration service publishes our Ranorex reports as html. (i.e.: it renames the rxlog => html, and the rxlog.data => html.data).

This allows the reports to be viewed in the browser.

The problem though, is that some change in Chrome v48 means that the report no longer loads. I think Chrome is blocking the following call:

Code: Select all

xmlhttp.open('GET', url, false);
which I presume loads the data (html.data) file.

Would anyone know whether there is a config item in Chrome that can restore the ability to view reports, or should my department just advise everyone to use IE or FireFox instead? (as those two browsers are fine at the moment).

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Reports not loading in Chrome v48

Post by Support Team » Fri Jan 29, 2016 2:21 pm

Hello jasoncleo,

The reason that Chrome blocks the Ranorex Report is the Same-orgin policy.

If you want to view the Ranorex Report in Chrome you have to start Chrome with the command line argument '--disable-web-security'.

Sincerely,
Johannes
.
Image

User avatar
jasoncleo
Posts: 37
Joined: Mon Jun 08, 2015 7:37 am

Re: Ranorex Reports not loading in Chrome v48

Post by jasoncleo » Mon Feb 01, 2016 1:55 am

Thank you Johannes for explaining that to me. I'll let the team know here at my end.

Cheers,
Jason