Ranorex Spy is generating erratic C# code

Bug reports.
Wooltown
Posts: 2
Joined: Thu Jan 10, 2013 8:34 am

Ranorex Spy is generating erratic C# code

Post by Wooltown » Mon Aug 05, 2013 10:11 am

When I generate C# code from Ranorex Spy, It sometimes generates erratic code. See my example below, a ">" is missing on the item info object, it generates "/// </summary", it should be: "/// </summary>".

Error Message from Visual Studio:
Warning 1 XML comment on 'MyTestProject.ECOMREPO1.HeaderImageInfo' has badly formed XML -- 'A name contained an invalid character.' C:\Project\UI_Model\ECOMREPO1.Repository.cs 107 9

Code: Select all

   /// <summary>
        /// The HeaderImage item.
        /// </summary>
        [RepositoryItem("13f1ae53-c7d7-4bce-af4b-7356aa3ecf02")]
        public virtual Ranorex.ImgTag HeaderImage
        {
            get
            {
                 return _headerimageInfo.CreateAdapter<Ranorex.ImgTag>(true);
            }
        }

        /// <summary>
        /// The HeaderImage item info.
        /// </summary
        [RepositoryItemInfo("13f1ae53-c7d7-4bce-af4b-7356aa3ecf02")]
        public virtual RepoItemInfo HeaderImageInfo
        {
            get
            {
                return _headerimageInfo;
            }
        }
I hope my description of the problem is easy to understand.

Regards
Sven

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Spy is generating erratic C# code

Post by Support Team » Mon Aug 05, 2013 9:40 pm

Thank you for reporting this issue. We pinned down the problem and are going to fix it with the next Ranorex release.

Thanks again and regards,
Alex
Ranorex Team
.
Image