Ranorex Spy recognize same objects differently

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
przemekak
Posts: 1
Joined: Wed Jun 18, 2014 12:17 pm

Ranorex Spy recognize same objects differently

Post by przemekak » Wed Jun 18, 2014 2:21 pm

Hello,

I have an issue with object recognition.
I am trying to automate Team Explorer in Visual Studio and have to run VS as different users for different tests.
Unfortunately starting VS as different user result in different path to same item.

Attached are two snapshots of one of the popup form that cause problems.
Both of them are representing same item, but one is from VS started as me (administrator) second is started by our test-user.

And as you can see there are recognized different items (elements vs containers, and also sometimes different tree structure).

I need to get same result in both cases.

Those snapshots were taken on Windows Server 2008 R2 Standard, Service Pack 1.
Using Ranorex Studio Version 5.0.3.18203.
When perform same actions on another PC with Win7, I always get same results (like in VS1 attachment).

I didn't get any Technology limitations warnings (like when I would try to track
from spy opened by test-user user on VS opened by me, which is understandable as test -user doesn't have access to my user files).

Would appreciate any help.

Regards,
Przemek
Attachments
VS2.rxsnp
(76.99 KiB) Downloaded 92 times
VS1.rxsnp
(24.05 KiB) Downloaded 84 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Spy recognize same objects differently

Post by Support Team » Tue Jun 24, 2014 2:49 pm

Hi all,

I just want to inform you that Przemek also contacted us by email. We will update this forum post as soon as we were able to resolve this problem.

Regards,
Markus (S)
.
Image