Ranorex stops saving changes to recording module

Ask general questions here.
caleb
Posts: 24
Joined: Mon Jul 08, 2013 3:35 am

Ranorex stops saving changes to recording module

Post by caleb » Fri Nov 01, 2013 4:29 am

Hi

A small team for 4 of us are developing tests against windows and ios applications with Windows 7 and Ranorex 4.1.1. We have found that after some time the changes made to a recoding module are not saved to disk, they appear to be held in memory and the module will execute when run within Ranorex. But as soon as the Ranorex IDE is closed the changes are lost. This can also be observed when attempting to commit changes to version control with the IDE still open and the file diffs show that not all of the changes are present in the file.

All four of us have experienced this problem but I haven't seen anyone else mention it on the forum, so would be interested to hear if anyone else is seeing this. Is it a known issue?

Our current workaround if we notice this happening is to save the recording module as a separate file, then restart Ranorex and copy the contents back into the original recording module.

Thanks

Caleb

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex stops saving changes to recording module

Post by Support Team » Mon Nov 04, 2013 11:26 am

Hi,
caleb wrote:All four of us have experienced this problem but I haven't seen anyone else mention it on the forum, so would be interested to hear if anyone else is seeing this. Is it a known issue?
Would it be possible to upgrade to Ranorex 4.1.2 and try it again on one machine? We have a few known issues with Source Control and the Ranorex Views and we are currently investigating this issues. Those issues should be fixed in one of the upcoming versions of Ranorex, we already fixed a few with Ranorex 4.1.2.

Regards,
Peter
Ranorex Team
.
Image

caleb
Posts: 24
Joined: Mon Jul 08, 2013 3:35 am

Re: Ranorex stops saving changes to recording module

Post by caleb » Wed Nov 06, 2013 2:07 am

Thank you, we have upgraded our team to 4.1.2 and my impression after one day is that stability seems to have improved. There are still some quirks around saving occasionally but it's happening far less often. If we get reliable steps to reproduce anything I will let you know.