Ranorex Studio 2.3.9 and .NET

Ranorex Spy, Recorder, and Studio.
SanMan
Posts: 151
Joined: Tue Apr 13, 2010 9:59 am

Ranorex Studio 2.3.9 and .NET

Post by SanMan » Mon Jan 13, 2014 1:32 pm

When trying to start Studio, get error notification about .NET Framework version.

I have disabled (renamed v2.0.50727)

I have .NET v4.0.30319 installed

Is it possible to start Ranorex Studio without v2.0 ?

User avatar
mebner
Posts: 61
Joined: Tue Dec 17, 2013 6:42 pm

Re: Ranorex Studio 2.3.9 and .NET

Post by mebner » Tue Jan 14, 2014 6:43 pm

Hi,

May I ask you to answer the following questions?
I am not sure what you mean with renaming of the .Net version, where did you rename it?
Why have you renamed it?
Which error notification do you get?

Thanks,
Markus

SanMan
Posts: 151
Joined: Tue Apr 13, 2010 9:59 am

Re: Ranorex Studio 2.3.9 and .NET

Post by SanMan » Wed Jan 15, 2014 11:54 am

C:\Windows\Microsoft.NET\Framework
renamed v2.0.50727 folder to _v2.0.50727

I need to have .NET 2.0 disabled / uninstalled from Windows7 (cannot uninstall it so renamed the folder)

Error message attached
Attachments
ranorex_error.png
ranorex_error.png (49.33 KiB) Viewed 634 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex Studio 2.3.9 and .NET

Post by krstcs » Wed Jan 15, 2014 3:03 pm

You cannot uninstall .NET 2.0 from Windows 7. It is built into Windows 7. And, renaming the folder does not uninstall the application, and can cause your system to become unstable and is, therefore, not recommended.


Can you please tell us why you want to disable .NET 2.0?

I cannot think of a requirement that would be served by removing a part of the Windows operating system. If your SUT is designed to run on Windows 7, then it should be designed to work with/around .NET 2.0 (even if it isn't using .NET). For example, Java applications may not need access to the .NET framework, but they do not require the removal of .NET in order to function correctly.

So, your Windows 7 test environment should include .NET 2.0 in order to ensure that your SUT works on that platform correctly.
Shortcuts usually aren't...