Ranorex Studio IDE freezes if user clicks soon after loading

Bug reports.
User avatar
jasoncleo
Posts: 37
Joined: Mon Jun 08, 2015 7:37 am

Ranorex Studio IDE freezes if user clicks soon after loading

Post by jasoncleo » Thu Jul 09, 2015 4:13 am

Environment:
Ranorex 5.3.0
Windows 7 Enterprise x64
Virtual Machine - hosted in VM WorkStation 10


We have found that with one of our larger Ranorex solutions where there are a 26 projects, that when we open the solution in Ranorex, after the projects are all loaded, there can be a few seconds while the status bar shows that it is parsing all the projects (while the IDE has displayed all the projects and modules, and tabs have opened to last edited files).

If the user happens to click anywhere while it is still parsing the projects, then the Ranorex IDE will freeze as soon as it finishes parsing and stops responding to any input, requiring the user to kill it from the Task Manager.

We have found that the user needs to ensure that Ranorex has finished parsing the projects before trying to interact with the IDE, otherwise this freeze issue occurs almost 100% of the time.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex Studio IDE freezes if user clicks soon after loading

Post by krstcs » Thu Jul 09, 2015 1:27 pm

First, try it on a non-VM system. If it still happens then it might be an issue. I haven't seen it on my non-VM system.

Second, try upgrading to a supported version. 5.3.3 is the latest in the 5.3.x line. 5.4.0 is the current version. 5.3.0 is no longer supported. There have been numerous bug fixes and feature enhancements.
Shortcuts usually aren't...

dmitry.abramov
Posts: 10
Joined: Wed Jan 28, 2015 3:41 pm

Re: Ranorex Studio IDE freezes if user clicks soon after loading

Post by dmitry.abramov » Thu Jul 09, 2015 3:17 pm

Hello,

Possibly we have similar or related issue. After upgrading to version 5.4 on one of machines Ranorex Studio often can't build solution. After starting build ranorex ten minutes switching between "run" and "not responding" statuses and nothing happen (build or update files progress not shown). Even if we wait parsing files problem is repeated.

Enviroment
Windows 7 x64 Service Pack 1
No virtual machine

Dmitry

User avatar
jasoncleo
Posts: 37
Joined: Mon Jun 08, 2015 7:37 am

Re: Ranorex Studio IDE freezes if user clicks soon after loading

Post by jasoncleo » Fri Jul 10, 2015 4:04 am

Hi krstcs,

Thank you for the tip. I tried it on a spare Win 8.1 x64 VM with Ranorex 5.4.0 and I found that did not display the freezing behaviour for the scenario I described, so I will be recommending the team at my end to transition to 5.4.0.

Part of the reason why we'd kept with 5.3.0, was because Ranorex embeds its version number in a variety of the Ranorex files, and if we had people at different versions, then it just adds to unnecessary 'noice' in the VCS with commits. As 5.3.0 mostly worked, we didn't pursue updating.

You also mention about trialling outside of the VM, I had seen the issue also occur on a physical machine as well. We mostly work within VMs though at my company as the environments are more controlled. Our AUT are not always neat installs, and a VM allows for these to be easily rolled back to clean states, whereas this is not so easily achieved with a physical machine.

In the end, it looks like 5.4.0 has resolved this issue, so that is a happy outcome for us.

Jason