Ranorex studio is ignoring breakpoints

Ranorex Spy, Recorder, and Studio.
ian807
Posts: 6
Joined: Wed May 08, 2019 7:57 pm

Ranorex studio is ignoring breakpoints

Post by ian807 » Thu Jul 18, 2019 8:40 pm

I'm running Ranorex 9.1.0
  • From the main menu, "Debug > Debugging Enabled" is checked.
    I press F7 to put a breakpoint on a line. It shows a filled, red circle, not a hollow circle.
    On the tab, I select the "Run Code" button
.

Expected result: The system would run to the breakpoint and highlight it.

Actual result: The system sails right past the breakpoint and runs the entire script.

Note: It doesn't matter where I put the breakpoint(s) in the script. The IDE never stops until the script completes.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5181
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex studio is ignoring breakpoints

Post by odklizec » Fri Jul 19, 2019 8:35 am

Hi,

I'm using breakpoints on daily basis and I've never experienced such issue. Which leads me to believe, that there is a problem with your machine (missing/corrupted runtime libs or .Net) or Ranorex installation itself? Have you tried to completely uninstall and reinstall Ranorex? At next, please check, if there are installed all required runtime libs on your machine, eventually, reinstall them:
https://www.ranorex.com/help/latest/ran ... uirements/

BTW, have you tried debugging with newly created solution and on another computer?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration