Ranorex Studio is not able to find an object during playback

Ranorex Spy, Recorder, and Studio.
ohm
Posts: 27
Joined: Thu Dec 03, 2009 7:27 pm

Ranorex Studio is not able to find an object during playback

Post by ohm » Thu Jul 15, 2010 9:40 pm

I am a paid ranorex subscriber and I am having this problem with Ranorex studio.

Ranorex is failing to find and click a button during playback. This button appears during an order cancellation process. During this process after pressing 'End Call' button in page 1, page 2 appears with 'Cancel' button. When I try to use 'Highlight Element' or 'Play From Here', 'Cancel' button gets highlighted and pressed. But when I run the whole script I am getting following error:

Ranorex.CapabilityNotSupportedException: Item 'OMS_Page.Cancel.Button_OK_to_cancel' is no Button. ---> Ranorex.CapabilityNotSupportedException: The element does not support the required capability 'button'.
--- End of inner exception stack trace ---
at Ranorex.Core.Repository.RepoItemInfo.CreateAdapter[T](Boolean throwException)
at OMS_Existing_Customer.OMS_Existing_CustomerRepositoryFolders.CancelFolder.get_Button_OK_to_cancel() in c:\Documents and Settings\Desktop\Ranorex Smoke Scripts\OMS Existing Customer\OMS Existing Customer\OMS Existing CustomerRepository.cs:line 2267
at OMS_Existing_Customer.Cancel.Start() in c:\Documents and Settings\Desktop\Ranorex Smoke Scripts\OMS Existing Customer\OMS Existing Customer\Cancel.cs:line 55
at OMS_Existing_Customer.Program.Main(String[] args) in c:\Documents and Settings\Desktop\Ranorex Smoke Scripts\OMS Existing Customer\OMS Existing Customer\Program.cs:line 45


Please advise.
Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Studio is not able to find an object during playback

Post by Support Team » Fri Jul 16, 2010 11:23 am

Hi,

Please can you post us a Ranorex Snapshot of the "Button" where you get this error message.
http://www.ranorex.com/support/user-gui ... html#c2072

It seems the button you want to automate is no button. This is the reason why you get the error message "The element does not support the required capability 'button'.". Please, read the corresponding help in the Ranorex User Guide:
http://www.ranorex.com/support/user-gui ... apter.html

Thanks and Regards,
Peter
Ranorex Support Team
.
Image