Ranorex studio with .Net 4.5

Ranorex Spy, Recorder, and Studio.
Aralmo
Posts: 5
Joined: Thu Apr 04, 2013 5:09 pm

Ranorex studio with .Net 4.5

Post by Aralmo » Mon Apr 08, 2013 4:33 pm

[Moved from automation api, created it in the wrong place]

Hi, as far as i can see Ranorex studio only allows to set the project target framework to .Net 4.0, is that ok? i am trying to add some external references that are in 4.5 wich i will use to do database initialization etc..
Is 4.5 not supported by the studio? any idea on how to solve this problem?

[Edit] I just need to know if .Net 4.5 is supported as target framework, and if it is how i do to enable it in the studio. If not will look for an alternate solution. Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex studio with .Net 4.5

Post by Support Team » Wed Apr 10, 2013 3:22 pm

Hi,

It is not yet possible to select the .Net 4.5 framework in the project settings in Ranorex Studio.
As a current workaround you could "manually" change the "<TargetFrameworkVersion>" setting of the csproj file to v4.5, but please keep in mind that the setting will be "reverted" when the project settings are updated.

Regards,
Markus
.
Image

Aralmo
Posts: 5
Joined: Thu Apr 04, 2013 5:09 pm

Re: Ranorex studio with .Net 4.5

Post by Aralmo » Thu Apr 11, 2013 8:31 am

Thanks.