Ranorex Studio won't work after PC change

Ranorex Spy, Recorder, and Studio.
AndrewL
Posts: 1
Joined: Tue Oct 15, 2013 8:50 am

Ranorex Studio won't work after PC change

Post by AndrewL » Tue Oct 15, 2013 8:53 am

Apologies for the long read.

Until last week I was successfully using Ranorex 4 on a Windows 7 SP1 x86 PC. I now have a new PC - Windows 8 x64 - but Ranorex doesn't seem to like it. I've copied my existing solutions to it (into the same directory structure, and browsed them into Ranorex) but they're both unusable. It seems related to the repository - in any .rxrec file I open, the Record button flashes on and off constantly, and every row flashes a red exclamation mark saying 'the repository item can not be found.'

If I click on the .rxrep file, it's a blank page. The thing is that if I copy the same solutions to a different Win 8 x64 machine, they work fine. So Win 8 isn't the problem, and nor are the solutions themselves. I considered permissions being the issue - but the same happens if I log in as local Administrator, and if I run the program as Administrator. What worked temporarily was moving the solution out of its default directory (in My Docs) and pasting it into ProgramData\Ranorex. At the same time I added 'Everyone - Full Control' to the solution folder, and also selected 'Replace all child object...' in the Advanced permissions. This worked for one of my two projects - briefly. After a little while, a message popped up saying that the solution had been changed externally, and did I want to reload? I said yes, and of course immediately everything started flashing again and I'm back to square one.

Anyone any ideas?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex Studio won't work after PC change

Post by Support Team » Mon Oct 21, 2013 1:43 pm

Hello,

Which Ranorex version do you use on your PC?
Please try to uninstall Ranorex completely, restart your computer and install it again.
Then, please copy your solution again and verify if the repository file is located in your project folder and not empty. Finally, open Ranorex and verify if it worked.

Thanks in advance.

Regards,
Markus (T)
.
Image