Ranorex SVN 1.6?

Ask general questions here.
RanoTester
Posts: 18
Joined: Mon Jan 14, 2013 7:16 pm

Ranorex SVN 1.6?

Post by RanoTester » Wed Nov 02, 2016 8:58 pm

Hi - We are currently on Ranorex version 5.4.6 and are using SVN 1.6. It is working fantastic. We need to keep using SVN 1.6. We are about to upgrade to Ranorex 6.1.1, but see that Ranorex support for 1.6 was dropped starting with Ranorex 6.0.0 (May 10, 2016). I presume SVN 1.6 is no longer supported in 6.1.1 either.

Before we proceed forward with upgrading to 6.1.1., we have a few questions.

1. What is the reason for dropping support for SVN 1.6?

2. What versions of SVN are supported currently in Ranorex 6 .1.1? SVN 1.7 and higher?

3. If we do upgrade to 6.1.1, would we expect to still see SVN 1.6 as an option in Options > Subversion Options? Another way of phrasing this is, would we expect to still see (in Ranorex 6.1.1) the following SVN 1.6 folder in the Windows directory where the program files are installed? This is the directory where SVN 1.6 appears in for 5.4.6:
--> C:\Program Files (x86)\Ranorex 5.4\RanorexStudio\AddIns\AddIns\Misc\SubversionAddin\SharpSvn1.6

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Ranorex SVN 1.6?

Post by odklizec » Thu Nov 03, 2016 11:05 am

Hi,

Ranorex GUI is based of SharpDevelop GUI (v 4.x). So if SharpDevelop drops support for something, Ranorex drops it, most likely, too ;)

Ranorex 6.1.1 currently installs SVN 1.8. However, it should still be possible to install older versions of SVN (see this user guide paragraph how). But as stated on sharpsvn page, the SVN 1.6 SharpDevelop addin is available, just 'unsupported' ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Ranorex SVN 1.6?

Post by krstcs » Thu Nov 03, 2016 3:56 pm

The other issue is that SVN 1.6 is no longer supported by Apache, so you should really move away from it anyway.

Keeping tools up-to-date is part of the process of making software and we all have to do it or we risk making software that is already out-of-date when we release it.
Shortcuts usually aren't...

RanoTester
Posts: 18
Joined: Mon Jan 14, 2013 7:16 pm

Re: Ranorex SVN 1.6?

Post by RanoTester » Thu Nov 03, 2016 10:22 pm

Thanks to both of you that replied. The problem is considered resolved.

Notes:
1. Today, we were able to successfully upgrade from Ranorex 5.4.6 to 6.1.1.

2. Once on 6.1.1, we saw that only SVN 1.7 and 1.8 were available in C:\Program Files (x86)/Ranorex 6.1/RanorexStudio/AddIns/SourceControl/SubversionAddin. So, in that directory, we deleted the 'SharpSvn1.7' folder, thus leaving only 'SharpSvn1.8' .

3. We then un-installed Tortoise SVN 1.6 Client from those machines, proceeded to then install SVN 1.8, and upgrade (via Windows Explorer) our Ranorex subversion files to SVN 1.8 via right-click > SVN Upgrade working copy.

4. Once that was done, we were able to open that project from within Ranorex 6.1.1, rebuild solution, and perform SVN Commit / SVN Update as normal.