Ranorex unable to open any browser in Windows Server 2012

Ask general questions here.
jamesl
Posts: 3
Joined: Fri Jun 10, 2016 3:38 pm

Ranorex unable to open any browser in Windows Server 2012

Post by jamesl » Thu Jul 06, 2017 10:14 pm

I have Ranorex 6.0.1 installed on Windows Server 2012 and am unable to open any browser through recordings or code (Host.Local.OpenBrowser()).
  • I am a local admin on the machine
  • IE has Enable Third Party Extensions turned on, Enhanced Protection off
  • I thought it was isolated to IE at first, but I am also unable to launch Chrome
  • I even tried creating a recorded action to open application -> Chrome/IE and neither of those worked. Opening any other application works fine
  • There's no error, it just straight up doesn't open the browser
  • Both browsers open fine when started manually
I'm stumped. Is there a global security policy that could prevent an application like Ranorex from starting a browser? Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex unable to open any browser in Windows Server 2012

Post by Support Team » Fri Jul 07, 2017 7:55 pm

Hi James,

Please note that Ranorex 6.0.1 is not supported anymore. May I ask you to install Ranorex 6.2.1 or Ranorex 7.1 to see if this issue still occurs?
Both versions can be found in our download archive.

Looking forward to your response.

Regards,
Markus (S)
.
Image

jamesl
Posts: 3
Joined: Fri Jun 10, 2016 3:38 pm

Re: Ranorex unable to open any browser in Windows Server 2012

Post by jamesl » Mon Jul 10, 2017 3:13 pm

Hi Markus,

I installed 6.2.1 and this issue still occurs. Another thing I noticed was when I start a recording, Ranorex Studio has no issue opening any browser to begin recording. It is only playback that has the issue of opening the browser. I do not know if the mechanism to open the browser for recording purposes is connected in any way to the opening of the browser for playback, but thought I'd share that observation.

Any ideas?

Thanks,
James

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex unable to open any browser in Windows Server 2012

Post by Support Team » Tue Jul 11, 2017 6:20 pm

Hi James,

Thank you for the update.

Would you mind sending an email direct to [email protected] (for US based customers) or [email protected] (for other locations). I'd like to take a look at this issue directly during a remote session.

Thank you.
Regards,
Markus (S)
.
Image

jamesl
Posts: 3
Joined: Fri Jun 10, 2016 3:38 pm

Re: Ranorex unable to open any browser in Windows Server 2012

Post by jamesl » Wed Jul 19, 2017 6:31 pm

It appears the problem ended up being some sort of security policy around the C drive on our Windows 2012 machine. Apparently executing the test suites from a different drive solved our problem.