Ranorex v5.02 Forward compatibility

Ask general questions here.
[email protected]
Posts: 1
Joined: Sun Nov 10, 2013 10:13 am

Ranorex v5.02 Forward compatibility

Post by [email protected] » Thu May 22, 2014 12:02 pm

Hi,

We have compiled our Ranorex project using Ranorex studio v5.02 and the project binaries can't be executed using Ranorex Test suite runner v4.1.5.

Could you please elaborate?

Thanks.
--Eli

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Ranorex v5.02 Forward compatibility

Post by Support Team » Thu May 22, 2014 4:16 pm

This is by design. When you upgrade from one major version to the next, you have to recompile the binaries. Only when you upgrade to new service releases or minor versions within a major version, you do not need to recompile.

This is required because of possible binary breaking changes we allow to be introduced with new major versions. Thank you for your understanding!

Regards,
Alex
Ranorex Team
.
Image